Boo
./1
Folco - Posté le 04/09/2011 à 20:02 Membre depuis le 18/06/2001, 29770 messages
yop,


J'essaye de relancer gcc4ti en ligne de commande pour la première fois depuis un bail suos Win XP.
Quand je tape "tigcc" dans un shell, j'obtiens ça :
'tigcc' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.

Et j'ai rebooté depuis l'installation. Est-ce normal ? Je croyais avoir déjà invoqué tigcc sous Win en ligne de commande, sans problème.


Ca semble pas être trop grave, je dois pouvoir rajouter le path vers tigcc dans le path du système (ou de mon user, ça doit être mieux).
Au passage, c'est pas recommandé de mettre program files dans le path sous Windows ?
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
./2
Zerosquare - Posté le 04/09/2011 à 20:21 Membre depuis le 27/04/2006, 43196 messages
Folco (./1) :
Au passage, c'est pas recommandé de mettre program files dans le path sous Windows ?
Ben ça ne va pas t'aider beaucoup, les sous-répertoires du %PATH% ne sont pas explorés. Donc à moins que t'installes directement tout dans Program Files sans créer de sous-répertoires... cheeky
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
./3
Folco - Posté le 04/09/2011 à 20:22 - Edité par Folco le 04/09/2011 à 20:23 Membre depuis le 18/06/2001, 29770 messages
Ah ok c'est pas récursif, donc faut que j'ajoute à la main les répertoires des programmes que je veux lancer en ligne de commande, merci.

Erf, si je définis PATH pour mon compte, ça va overrider les paramètres systèmes, les compléter, ou créer un problème ? grin
J'aime pas donner des droits au système à tout bout de champs.
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
./4
Zerosquare - Posté le 04/09/2011 à 20:23 Membre depuis le 27/04/2006, 43196 messages
Yep (mais c'est pareil sous Linux, non ?)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
./5
Folco - Posté le 04/09/2011 à 20:25 Membre depuis le 18/06/2001, 29770 messages
J'ai édité. Oui, je crois que c'est pareil, mais je me suis pas posé la question (/usr/bin:~/bin powa tongue)
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
./6
Folco - Posté le 04/09/2011 à 20:56 Membre depuis le 18/06/2001, 29770 messages
Bizarement, quand je lance une console depuis le menu démarrer (Exécuter : cmd), j'arrive à invoquer tigcc.
Quand j'utilise le menu Outils de Code::Blocks (qui permet de lancer différents programmes externes, ça doit être assez classique comme menu), ben ça fait comme si j'avais pas rajouté "program files\gcc4ti" dans le path.

Voici le screen des deux consoles juxtaposées :
#tromb# Fichier joint : by0Q (console.png)

Une idée d'où ça pourrait venir ?
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
./7
Folco - Posté le 04/09/2011 à 20:58 Membre depuis le 18/06/2001, 29770 messages
Tiens, je retrouve ce vieux script dans eexec :
echo off

tigcc -v eexec.s -o eexec

move eexec.??z ../

del *.o *.??z

Je pense que ça marchait.
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
./8
Lionel Debroux - Posté le 04/09/2011 à 21:03 Membre depuis le 28/10/2001, 7564 messages
"#" n'est pas reconnu en tant que commande interne -> on dirait que tu exécutes un script shell sh sur Windows ?
Est-ce que tu as ajouté $TIGCC au PATH global du système, puis démarré C::B ?
avatar Membre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
./9
Zerosquare - Posté le 04/09/2011 à 21:05 Membre depuis le 27/04/2006, 43196 messages
(Folco : qu'est-ce que tu essaies de cacher sur ton screenshot ? tongue)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Folco - Posté le 04/09/2011 à 21:10 Membre depuis le 18/06/2001, 29770 messages
Lionel Debroux (./8) :
"#" n'est pas reconnu en tant que commande interne -> on dirait que tu exécutes un script shell sh sur Windows ?

Je me suis loupé, l'habitude grin
Lionel Debroux (./8) :
Est-ce que tu as ajouté $TIGCC au PATH global du système, puis démarré C::B ?

Ah non, j'ai pas défini cette variable, j'ai juste ajouté "c:\program files\gcc4ti" à %PATH%.
Je vais essayer en modifiant le path ET en rajoutant la variable %TIGCC%
Zerosquare (./9) :
(Folco : qu'est-ce que tu essaies de cacher sur ton screenshot ? /v31/gfx/s/tongue.gif )

Rien, je crois qu'il y a un très vilain pirate qui a patché le binaire de ma console, c'est du beau ça ##sifflote## (d'ailleurs je me suis loupé, le "3.0" n'a rien à faire là #triso#)
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Zerosquare - Posté le 04/09/2011 à 21:15 Membre depuis le 27/04/2006, 43196 messages
Mouais tongue

Je pense à un truc, il ne faut pas des guillemets autour de C:\Program Files\gcc4ti ? (il y a une espace dedans)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Pen^2 - Posté le 04/09/2011 à 21:16 Membre depuis le 10/06/2001, 30209 messages
Folco (./6) :
Une idée d'où ça pourrait venir ?
As tu relancé code blocks ? La console qu'il lance hérite probablement de son environnement.
Folco - Posté le 04/09/2011 à 21:31 Membre depuis le 18/06/2001, 29770 messages
Bon, j'ai essayé vos suggestions (ajout de %TIGCC% dans les variables système, pas locales), ajout de guillemets pour définir cette variable (à noter que %PATH% n'en a pas besoin), rien n'y fait :
#tromb# Fichier joint : 7kHg (console.png)
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Uther - Posté le 05/09/2011 à 08:50 Membre depuis le 10/06/2001, 6798 messages
Tu as pensé à redémarrer la console après avoir édité la variable? Ou peut-être redémarrer windows, mais la je suis moins sur.
avatar
Folco - Posté le 05/09/2011 à 08:54 Membre depuis le 18/06/2001, 29770 messages
Oui. Rien n'y fait, je dois rater un truc. sad
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
vince - Posté le 05/09/2011 à 10:14 Membre depuis le 11/11/2001, 109026 messages
Dans ces deux consoles, taper la commande "path" (toute seule sans argument ni espace à la fin) renvoie la même chose ? (au caractère près)

Code Blocks n'aurait pas un paramètre de rédéfinition du path ?

Dans les chemins de ton path(et dans l'ordre), y'aurait pas un path.exe, .cmd ou .bat qui trainerait ?

On peut voir le contenu de build.bat ?
avatar Webmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // http://www.yaronet.com/posts.php?s=6238
Uther - Posté le 05/09/2011 à 11:22 Membre depuis le 10/06/2001, 6798 messages
Essaie d'installer Gcc4ti dans un nom de répertoire sans espace pour voir. Le fait que "Program Files" soit en deux mot est un problème récurent sous windows.
avatar
vince - Posté le 05/09/2011 à 11:32 Membre depuis le 11/11/2001, 109026 messages
Ou alors tu utilises progra~1 comme nom (le 1 devant être remplacé par le bon si tu as plusieurs noms longs)
avatar Webmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // http://www.yaronet.com/posts.php?s=6238
Folco - Posté le 05/09/2011 à 15:17 - Edité par Folco le 05/09/2011 à 15:46 Membre depuis le 18/06/2001, 29770 messages
Je teste vos pistes. J'ai des résultats différents pour
echo %path%

Sous C::B :
c:\Program Files\Codeblocks\Mingw\bin;c:\Windows\system32;c:\windows;c:\windows\system32\webm

Et sur le Bureau :
c:\Windows\system32;c:\windows;c:\windows\system32\webm\c:program files\gcc4ti

Je vais voir sur le forum de C::B pourquoi il s'évertue à modifier le path sans mon accord.

Merci pour toutes vos réflexions et conseils.
[nosmile]
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Pen^2 - Posté le 05/09/2011 à 15:30 Membre depuis le 10/06/2001, 30209 messages
il semblerait que tu aies un smiley au milieu de ton path, le problème vient sans doute de là embarrassed

(effectivement, on dirait qu'il écrase carrément le path d'origine au lieu de concaténer #tritop#)
Folco - Posté le 05/09/2011 à 15:46 Membre depuis le 18/06/2001, 29770 messages
(grin)
(corrigé)
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
vince - Posté le 05/09/2011 à 15:49 Membre depuis le 11/11/2001, 109026 messages
je ne sais pas si ça vient de la correction mais tu pourrais confirmer qu'en vrai tu as un point virgule après webm\ ?
avatar Webmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // http://www.yaronet.com/posts.php?s=6238
Folco - Posté le 05/09/2011 à 16:06 Membre depuis le 18/06/2001, 29770 messages
Je confirme, problème de recopie, mais bien vu #hehe#
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Folco - Posté le 05/09/2011 à 18:17 Membre depuis le 18/06/2001, 29770 messages
Bon, problème trouvé. J'utilise ça : http://rocketdock.com/

Il se trouve que ce launcher doit garder un snapshot des variables d'environnements quand on l'installe, car C::B n'est pas dans le même environnement quand je le lance depuis le menu démarrer ou le dock.
La suppression/réinstallation de RocketDock corrige le problème.

Voili voilou, merci à tous pour tout, vos pistes, et ce que j'ai encore appris grâce à ce problème. smile
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Folco - Posté le 10/09/2011 à 15:28 Membre depuis le 18/06/2001, 29770 messages
Bon, puisqu'il m'arrive la même chose, mais sur ma Debian, je reviens vers vous cheeky (heureusement que j'ai pas mis l'OS dans le titre, ça permet de recycler ^^)

Configuration de l'environnement :
$ echo $SHELL
/bin/bash
$ echo $PATH
/home/folco/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:[b]/usr/local/share/gcc4ti/bin[/b]
$ echo $TIGCC
/usr/local/share/gcc4ti

Tout semble normal.
$TIGCC est défini dans mon .bashrc, $PATH y est complété (je l'ai fait à la main, mais a priori c'est la même chose que ce que fait le script d'install, de toute façon les variables me semblent bonnes).

Dans un shell (gnome-terminal ou xterm) :
$ tigcc
tigcc: no input file

Et je peux assembler des programmes, donc le path et $TIGCC sont bien bons.


Configuration de Code::Blocks :
J'utilise un outil pour me lancer mon script de build (en-tête : #!/bin/bash). Les paramètres de l'outil sont :
exécutable : ./build.sh
path : ${PROJECT_DIR}


Problème :
Si mon script invoque directement `tigcc' :
./build.sh: line7: tigcc: command not found [...]

Si mon script invoque `/usr/local/share/gcc4ti/bin/tigcc' :
Fatal error: TIGCC is not defined in the environment [...]


Alors que se passe-t-il ? J'ai paramétré C::B pour me lancer par défaut bash dans un xterm quand il me lance un shell. Qu'est-ce qui ne va pas ? Mon .bashrc semble complètement ignoré... Ca fait une heure que je piannote, je trouve rien...


(et encore, au début, je croyais que c'était parce que j'utilisais un trick pour faire faire un --noclose à gnome-terminal qui ne propose pas l'option, mais même pas : j'obtiens le même comportement avec un simple xterm lancé sans paramètres)

Vos avis et pistes vers lesquelles chercher sont les bienvenus, je vous en remercie d'avance. smile
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Lionel Debroux - Posté le 10/09/2011 à 15:46 Membre depuis le 28/10/2001, 7564 messages
Essaie d'ajouter un "source ~/.bashrc" explicite dans ton build.sh.
avatar Membre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
Folco - Posté le 10/09/2011 à 15:50 Membre depuis le 18/06/2001, 29770 messages
Même erreur, quelque soit l'invocation à tigcc.
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Lionel Debroux - Posté le 10/09/2011 à 16:31 Membre depuis le 28/10/2001, 7564 messages
Ca, c'est plus bizarre...
avatar Membre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
Folco - Posté le 10/09/2011 à 17:20 Membre depuis le 18/06/2001, 29770 messages
Et donc même quand je mets `TIGCC=/usr/local/share/gcc4ti' dans mon script, juste avant l'invocation à tigcc, j'ai le même message "TIGCC not declared in the environment [...]"
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Folco - Posté le 10/09/2011 à 17:24 Membre depuis le 18/06/2001, 29770 messages
Autres indices :
Quand je dis à C::B de me lancer un terminal, et que moi-même je table ./build.sh, ça marche. Les variables globales sont bonnes.
Quand je dis à C::B de me lancer ça : /bin/bash -c './build.sh, ça ne marche pas non plus.

Que puis-je fournir encore, comme indices, pour établir un diagnostic ?
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.