Boo
Folco - Posté le 27/11/2011 à 23:02 Membre depuis le 18/06/2001, 29833 messages
Mon xorg.conf est dans le post ./1, tout simplement.

J'ai juste rajouté une SubSection Display dans la Section Screen (Default Depth 24 et Modes "1680x1080"). Ca n'a rien changé.
Ce xorg.conf est celui que je trouve après une installation de X normale par le CD d'installation. C'est aussi celui que génère dpkg-reconfigure -phigh xserver-xorg
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 27/11/2011 à 23:13 Membre depuis le 16/12/2007, 902 messages
Ben oui c'est ce que je pensais, il n'est pas configuré ton xorg...
Si c'est ça, il manque la définition de tes périphériques.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection
LabibleATARI - Posté le 27/11/2011 à 23:24 Membre depuis le 16/12/2007, 902 messages
Fais une copie de ton xorg.conf en xorg.conf.bak et tests celui-ci pour voir



# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Monitor0"
HorizSync 30-111
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Screen0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1024x768"
EndSubSection
EndSection
Folco - Posté le 27/11/2011 à 23:26 Membre depuis le 18/06/2001, 29833 messages
Ah. Alors j'ai parcouru le man plusieurs fois, j'avoue que ça m'a paru très indigeste, même si j'y ai trouvé la manip pour la résolution.

Alors, comment fait-on pour définir ses périphériques ? Ca devrait ressembler au xorg.conf donné en exemple ici ? http://www.bouthors.fr/wiki/doku.php?id=linux:config:xorg
Où vais-je alors chercher toutes ces données, elles ne s'inventent pas...

(cross)

Super sympa, merci de m'aider. J'essaye immédiatement. happy
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 27/11/2011 à 23:34 Membre depuis le 16/12/2007, 902 messages
Non en effet rien ne s'invente ici, mais par truchement, tu vas y arriver. Ton message veux dire que xorg ne trouve pas de définition pour ton moniteur. C'est pour ça que les messages du /var/log sont importants.
Et de rien ; Linux est mon second violon d'ingre après Atari wink
vince - Posté le 27/11/2011 à 23:44 Membre depuis le 11/11/2001, 109036 messages
(erf, t'es sûr ? et tu saurai installer un serveur de mail simple&propre sur une debian ?)
avatar Webmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // http://www.yaronet.com/posts.php?s=6238
LabibleATARI - Posté le 27/11/2011 à 23:47 Membre depuis le 16/12/2007, 902 messages
Sinon une idée comme ça.
Tu télécharges une version live d'opensuse. Tu bootes dessus et tu recopies le xorg.conf généré durant la détéction.
Sax (l'utilitaire de détéction graphique) est très puissant et fiable. Après, tu recopies le xorg.conf généré sur ta Débian et le tour est joué #chinois#
LabibleATARI - Posté le 27/11/2011 à 23:49 Membre depuis le 16/12/2007, 902 messages
vince (./35) :
(erf, t'es sûr ? et tu saurai installer un serveur de mail simple&propre sur une debian ?)

Un gui peut être pratique pour l'administration. Et rien n'empêche de lancer Xorg à la demande plutôt qu'au démarrage système (init 3) wink
Folco - Posté le 28/11/2011 à 00:02 Membre depuis le 18/06/2001, 29833 messages
Ooooooooooooooooooohhhhhhhhhhh !!!!!!!!!!!!!!!!!!!! Ca marche !!!!! Dans mes bras !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! #boing# #bisoo##calin##love#grin

Enormissime happy

Seul truc, j'avais rajouté "1680x1080" dans les modes de profondeur 24. Mais il ne me propose pas plus que 1024*768, ce radin embarrassed
Je l'ai mis à la fin de la ligne, peut-être attend-il les résolutions dans un ordre, de la plus grande à la plus petite par exemple ? Je vais voir ça.
En tout cas c'est génial, il a l'air de tourner à 85 Hz en plus, c'est bien stable et tout, c'est juste parfait. Mille mercis happy

edit -> Bon, ça doit pas être une question d'ordre, ni de profondeur (j'ai rajouté ma résolution dans depth 16, on sait jamais). Mais l'essentiel est là, on paufinera ça demain, c'est déjà super happy
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 28/11/2011 à 08:50 Membre depuis le 16/12/2007, 902 messages
Ben voila, en cherchant grin
Pour paufiner la chose, et avoir des résolution et profondeurs de couleur adéquat, il faut que tu modifies la section monitor comme ça:

Section "Monitor"
Identifier "Monitor0"
HorizSync 30-111
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Screen0"
Monitor "Monitor0"
DefaultDepth 16

SubSection "Display"
Depth 16
Modes "1680x1080" "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1080" "1024x768"
EndSubSection
EndSection

Je supprime les profondeurs de couleur inutiles et j'ajoute la résolution souhaitée.
Pour le pilote, dans la section device, commence par replacer
Driver "vesa"
par
Driver "ati"
ou
Driver "radeon".

Perso ATI sous linux, j'ai décroché depuis que les drivers sont propriétaires.
LabibleATARI - Posté le 28/11/2011 à 09:45 Membre depuis le 16/12/2007, 902 messages
Pouf! pouf!
Je voulais dire la section Display pour les résolutions.
Tu noteras que la profondeur de couleurs par defaut se trouve dans la section Screen (DefaultDepth 16). Laisse comme ça surtout en vesa et pour les drivers libres par defaut (ati ou radeon)
Folco - Posté le 28/11/2011 à 17:56 - Edité par Folco le 28/11/2011 à 18:42 Membre depuis le 18/06/2001, 29833 messages
Merci mille fois, je vais tester. Sinon, un truc que je ne comprends pas, DefaultDepth 16, ça veut dire 16 bits pour les 3 couleurs (sans canal alpha si j'ai bien compris le man), donc j'imagine 4 ou 5 bits par couleurs ? Ca fait pas faible, vesa ne supporte pas 8 bits/couleurs ?

Bon, je vais déjà essayer ça, merci encore #chinois#
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 28/11/2011 à 18:39 Membre depuis le 16/12/2007, 902 messages
De rien encore ! #chinois#
Si je ne m'abuse, 16bit, c'est 16 millions de couleurs... En tous cas, c'est plutot bien comme réglage.
Pour moi, la prochaine étape, c'est tester linux et freemint sur Atari. Amuses toi bien ! et n'hesites pas si tu as d'autres questions.
Folco - Posté le 28/11/2011 à 18:42 Membre depuis le 18/06/2001, 29833 messages
Bon, alors pour les drivers ati et radeon, on verra après. J'ai pas regardé les logs, mais X ne se lance pas.
Mais en attendant, il n'y a pas de raison que ça ne marche pas avec vesa. smile


J'ai donc essayé le 1680x1050 (et non 1080 ><), en virant le 1024x768 : out of range.
J'ai donc trifouillé un peu, et essayé ça : http://linux.die.net/man/1/gtf

J'ai donc eu ça :
$ gtf 1680 1050 60
# 1680x1050 @ 60.00 Hz (GTF) hsync: 65.22 kHz; pclk: 147.14 MHz
Modeline "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync

J'ai changé la fréquence parce que mon moniteur est donné pour cette résolution à 60 Hz, pas à 85.

Et là pareil, out of range. sad

Voici le xorg.conf que j'avais fait (j'avais rajouté une option PreferredMode et les fréquences) :
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "Monitor0"
Modeline "1680x1050_60.00" 147.14 1680 1784 1968 2256 1050 1051 1054 1087 -HSync +Vsync
Option "PreferredMode" "1680x1050_60.00"
EndSection

Section "Screen"
Identifier "Screen0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1680x1050_60.00" "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1050_60.00" "1024x768"
EndSubSection
EndSection

Quoi essayer ?

(cross -> oh t'inquiète pas, c'est pas tout à fait fini, mais une fois la résolution bonne ça sera bon avec xorg grin)
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Folco - Posté le 28/11/2011 à 18:45 Membre depuis le 18/06/2001, 29833 messages
J'ai viré les fréquences Vert et Hz, fallait pas peut-être ?
Cette page : http://xtiming.sourceforge.net/cgi-bin/xtiming.pl me donne ça : 3.8µs en horizontal, 150µs en vertical.

Et quand je tape ça :
$ xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 76.0*
800x600 73.0
640x480 73.0
720x400 71.0
640x350 0.0
512x384 0.0
320x240 0.0
320x200 0.0

Snif, pourquoi ? #ouin#
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 28/11/2011 à 18:51 Membre depuis le 16/12/2007, 902 messages
D'ou vient ta modeline ? il faut la générer en fonction des spécificités de ton moniteur...
Zerosquare - Posté le 28/11/2011 à 18:52 Membre depuis le 27/04/2006, 43249 messages
LabibleATARI (./42) :
Si je ne m'abuse, 16bit, c'est 16 millions de couleurs...
Non, 16 bits c'est bien 65 536 couleurs, comme le dit Folco. 16 millions de couleurs, c'est 24 bits, ou alors 32 s'il y a un canal alpha ou 8 bits inutilisés (ce qui est le cas sur la plupart des cartes actuellement).
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Sally - Posté le 28/11/2011 à 19:04 Membre depuis le 16/06/2003, 24345 messages
DefaultDepth 16, ça veut dire 16 bits pour les 3 couleurs (sans canal alpha si j'ai bien compris le man), donc j'imagine 4 ou 5 bits par couleurs ?
Oui, mais bon c’est déjà pas mal hein. M’enfin si ta carte graphique supporte 24 bits dans la résolution que tu veux (ça devrait être le cas si elle a moins de 15 (bon allez 12) ans je pense, à moins que tu aies vraiment une résolution de taré), il n’y a aucune raison de ne pas mettre le DefaultDepth à 24... (et c’est effectivement 24 qui correspond à 16 millions et quelques de couleurs)

En fait le compromis résolution/nombre de couleurs (habituel dans les années 80-90 mais dont on n’a plus besoin de se préoccuper depuis un bout de temps), si je ne dis pas de connerie c’est juste une question de mémoire vidéo, si tu veux beaucoup de pixels ben il faut réduire le nombre de bits par pixel sinon ça tient plus.

(cross)
avatar « Le bonheur, c'est une carte de bibliothèque ! » — The gostak distims the doshes.
Forum Cultures du mondeforum littéraire
Membrane fondatrice de la confrérie des artistes flous.
L'univers est-il un dodécaèdre de Poincaré ?
(``[u]·[/u] powaaaaaaaaa ! #love#
Zerosquare - Posté le 28/11/2011 à 19:22 Membre depuis le 27/04/2006, 43249 messages
Sally (./47) :
En fait le compromis résolution/nombre de couleurs (habituel dans les années 80-90 mais dont on n'a plus besoin de se préoccuper depuis un bout de temps), si je ne dis pas de connerie c'est juste une question de mémoire vidéo, si tu veux beaucoup de pixels ben il faut réduire le nombre de bits par pixel sinon ça tient plus.
De bande passante aussi, il en faut forcément davantage en 24 (ou 32) bits qu'en 16, pour un même nombre de pixels par seconde. Mais ça fait très longtemps que ce n'est plus un goulot d'étranglement en effet (y'a assez de mémoire et de débit pour ne pas avoir à se poser la question).
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Folco - Posté le 28/11/2011 à 19:35 Membre depuis le 18/06/2001, 29833 messages
LabibleATARI (./45) :
D'ou vient ta modeline ? il faut la générer en fonction des spécificités de ton moniteur...

C'esty gtf qui me l'a donné, cf ./43
Mon moniteur devrait fonctionner dans cette résolution à 60 Hz. Apparemment, il y a encore un truc qui ne vas pas...

Je vais essayer avec XrandR : http://www.debian-fr.org/configuration-d-une-resolution-d-ecran-t20685.html
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Sally - Posté le 28/11/2011 à 19:46 Membre depuis le 16/06/2003, 24345 messages
Zerosquare > oui aussi c’est vrai, mais c’est pas cette limitation-là qu’on contournait avec les modes entrelacés ? ou il y avait une autre raison ? (genre la vitesse limite de balayage du moniteur ?)
avatar « Le bonheur, c'est une carte de bibliothèque ! » — The gostak distims the doshes.
Forum Cultures du mondeforum littéraire
Membrane fondatrice de la confrérie des artistes flous.
L'univers est-il un dodécaèdre de Poincaré ?
(``[u]·[/u] powaaaaaaaaa ! #love#
Zerosquare - Posté le 28/11/2011 à 19:50 Membre depuis le 27/04/2006, 43249 messages
Pour le mode entrelacé, c'est plutôt à cause des moniteurs qui suivaient pas, oui.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Folco - Posté le 28/11/2011 à 20:46 Membre depuis le 18/06/2001, 29833 messages
Bon, ben je n'arrive pas avec cette méthode : http://www.debian-fr.org/configuration-d-une-resolution-d-ecran-t20685.html sad
Je croyais que c'était la solution ultime, mais non...

Ca coince ici : xrandr --output DVI-0 --mode 1280x1024_75.00
Il me dit que la sortie DVI-0 n'existe pas. Mais VGA-0 non plus, VGA ou DVI non plus. J'ai regardé la doc de Xrandr, les mans de quelques commandes, je ne sais pas comment lister les sorties pour trouver le nom qu'il attend.
Mon moniteur a une entrée VGA, ma CG une sortie DVI, donc il y a un adaptateur entre les deux.

Je repense à ma solution de backporter le Xorg de Squeeze, qui me détecte tout très bien (il l'a fait pas plus tard qu'hier).

edit-> ben les backports ça marche pas, je m'y attendais, trop de choses incompatibles et cassées entre les deux distros, dont une libudev qui ne semble plus exister pour squeeze...
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 28/11/2011 à 21:39 Membre depuis le 16/12/2007, 902 messages
Je pense que ta modeline n'est pas correcte.
Prends les caractéristiques de ton moniteur et régénéré une modeline correcte sur ce site par exemple.
http://xtiming.sourceforge.net/cgi-bin/xtiming.pl
Folco - Posté le 28/11/2011 à 21:59 Membre depuis le 18/06/2001, 29833 messages
Il me donne cette Modeline :
Modeline "1680x1050@60" 154.20 1680 1712 2296 2328 1050 1071 1081 1103

Je remplace @60 par _60.00, mais ça ne marche toujours pas. Les seules indications que je lui ai fournies sont "1680", "1050", "60" (Hz).

Vers où essayer maintenant ? sad
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
Sally - Posté le 28/11/2011 à 22:04 Membre depuis le 16/06/2003, 24345 messages
Folco > tu as regardé ton xorg.0.log ? normalement si ta ligne est rejetée il doit te dire pourquoi (c’est paumé au milieu du fichier par contre, pour le trouver plus facilement tu peux l’appeler tototutu plutôt que 1680x1050_60.00 par exemple)
avatar « Le bonheur, c'est une carte de bibliothèque ! » — The gostak distims the doshes.
Forum Cultures du mondeforum littéraire
Membrane fondatrice de la confrérie des artistes flous.
L'univers est-il un dodécaèdre de Poincaré ?
(``[u]·[/u] powaaaaaaaaa ! #love#
LabibleATARI - Posté le 28/11/2011 à 22:53 Membre depuis le 16/12/2007, 902 messages
le pilote vesa donne aussi parfois des résultats mauvais.
la detection des frequences du moniteur peuvent être éronnées aussi (firmware foireux de l'ecran), ça m'est arrivé. Dans ce cas désactive edid en parametrant xorg ainsi.

Tentes au passage de mettre le pilote ati,il fait parti des pilotes de xorg, tu n'as rien à installer

Section "Device"
Identifier "Configured Video Device"
Driver "ati"
Option “IgnoreEDID” “true”
EndSection
LabibleATARI - Posté le 28/11/2011 à 22:55 Membre depuis le 16/12/2007, 902 messages
Sally a raison, tu devrais poster ton xorg.0.log , car il contient l'erreur rencontrée.
Folco - Posté le 28/11/2011 à 23:25 Membre depuis le 18/06/2001, 29833 messages
Ca marche, ça me redonne espoir, je verrai ça demain dorénavant, merci beaucoup smile
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.
LabibleATARI - Posté le 29/11/2011 à 00:09 Membre depuis le 16/12/2007, 902 messages
De rien vraiment !

Saint LabibleATARI, priez pour nous
Marrant je viens de voir ça ! grin

Allez en paix et que SainT TOS et que l'esprit de Tux soient avec vous !
Folco - Posté le 29/11/2011 à 00:25 Membre depuis le 18/06/2001, 29833 messages
Attends, ça fait des mois que c'est mon rêve de relancer cette distro, mais j'avais jamais persévéré cheeky
La dernière Fedora à proposer KDE 3 était la 8, ça remonte à loin la maintenance, tandis que Lenny est toujours maintenue. smile
Sinon je devrais switcher sur BSD il me semble, pour une distro récente avec KDE 3, mais je vais avoir beaucoup à réapprendre, je préfère capitaliser sur les petites choses que j'apprends ici et là avec Linux.
avatar <<< Kernel Extremist©®™ >>>
Saint Qt, priez pour nous.