1

Salut a tous!!

J'ai donc un sérieux problème avec Civillization III. J'ai achetté ce jeu que j'adore, il y a quelques années maintenant ( peu aprés sa sortie ).

Il a trés bien tourné sur mon vieux PC. Mais depuis que j'ai changé de machine, plus moyen. J'ai essayer sur 2 PC, un AMD 3000+ et un AMD 2000+, 512 mo de ram chacun. L'un avec une carte graphique banale, et l'autre avec une geforce.

Voisi ce qu'il se passe:

Installation, sans problème.

Lancement du jeu:
- boote sur le CD, et m'affiche la fenetre avec les choix "réinstaller", "jouer" etc...
- je selectionne "jouer"
- petite fenêtre bleue avec le sablier
- écran boir
- disparition du curseur

...et la, plus rien, tant que je ne fait pas quelque chose. Le PC n'est pas planté puisque je peux sortir avec le gestionnaire des taches et fermer l'application.

Dans le doute, j'ai installe le patch: "civilization_3_patch_v1.29f_francais_12031.exe".

Le résultat est le même.

La résolution de l'écran est de 1024*768 en 60Hz en permanance.

Si jamais quelqu'un a une idée...je suis preneur!!

wink

Merci d'avance.

2

Bonjour,

as tu essayé de lancer le jeu en sélectionnant une compatibilité pour windows 98 ?

3

C'est peut-être un problème avec le changement de résolution que fait Civ III en se lançant (systématique, même si ta résolution est déjà celle que le jeu utilise), ou avec la vidéo de lancement. Pour les désactiver, cherche le fichier .ini du jeu (dans son dossier, je ne sais plus son nom exact) et rajoute dedans "KeepRes=1" et "PlayIntro=0" (chacun sur une ligne distincte).
Pour la liste des balises modifiables dans le fichier ini, voir [URL=http://forums.civfanatics.com/showthread.php?t=118126#5]ce sujet (anglais)[/URL].
avatar

4

Merci pour vos suggestions.

Comment fais-ton pour selectionner une compatibilité win98?

Pour le reste je vais essayer.

Merci! wink

5

Pour affecter une compatibilité à un programme : clique droit sur son icône, dans le menu contextuel choisir propriétés, dans la fenêtre des propriétés choisir l'onglet compatibilité. Il reste à cocher l'activation de compatibilité et choisir le système d'exploitation pour lequel le programme est prévu. Cette manipulation résoud de drôles de problème, dernier exemple en date Bioshock s'exécutait sans son sur mon PC Vista, après avoir défini une compatibilité pour Windows XP SP2, j'ai enfin pu entendre quelque chose. Va comprendre Charles ! wink

6

Génial, je vais essayer ça.

Au passage, je vous cale le rpport d'erreur, au cas ou, ça puisse servir a quelque chose, moi, je trouve pas ça trés clair!

[URL=http://imageshack.us][IMG]http://img396.imageshack.us/img396/7684/raperrjr7.jpg[/IMG][/URL]


Je vais essayer la compatibilité win98, et je vous tiens au courant.

7

Bon, j'ai essayé toutes les compatibilités, et rien n'y fait. Merci quand même de m'avoir appris cette astuce, ça peut servir.

En postant je m'attendais, a ce que vous trouviez vite la réponse car je pensais ne pas être le seul dans ce cas. Mais a priori, je suis un cas isolé...c'est pas trés rassurant!!!

Bon, je vais épluchez les sites de FAQ, j'esperequ'on va trouver quelque chose, j'en ai un peu marre de Civnet! wink Bien qu'il soit excellent!

Je vous tiens au courant.

8

Faut dire que civ IV est sortit bien avant vista, du coup peu de personne ont tenté de faire tourner civ III sous vista (je suppose que c'est vista au vu de la fenêtre de rapport d'erreur qui n'a jamais eu cette gueule sous mon winXP).
Au passage, cette fenêtre n'indique quasiment rien sur la raison technique du problème, il aurait mieux valut avoir les infos données par le premier lien "Cliquer ici" en bas de celle-ci. M'enfin je n'aurai probablement pas été plus avancé, n'ayant pas vista.
avatar

9

Beh...non, j'suis sous XP!!!

Moi vista? JAMAIS! lol

Pour les "cliquez ici", je peux voir où ça me mene, mais sur ce PC, je n'ai pas la connexion net. Donc, au pire, j'installe civ3 sur le poste d'ou je suis en ce moment, vu que j'ai exactement le même problème sur les 2.

J'ai essayer, en le bootant sur un mode diagnostic, a partir de "MSCONFIG", mais rien n'a changé... sad

Je poursuis...

10

Bon, j'ai choppé un directX 8, et je l'ai installé...on ne sait jamais...

Rien de mieux je pense.

En montant le son, j'ai remarqué que j'entends un début de bande sonore genre "prrrrr". Donc, peut être que le jeu plante sur la carte son...enfin, je vais voir de ce côté.

Concernant le rapport d'erreur, est ce que ceci est plus utile?

[URL=http://imageshack.us][IMG]http://img150.imageshack.us/img150/4787/cliqicirj3.jpg[/IMG][/URL]




Encore merci de vous pencher sur mon cas désespéré!

11

Bon, beh rien de mieux...j'ai tout désinstallé, sans oublier de supprimer le dossier infogrammes à la main.
Puis, j'ai réinstallé le toutim. D'abord en choisissant la config mini et ensuite, j'ai recommence avec la config standart. Rien de neuf.

Par contre, j'ai installé Call To Power II ( a défaut de grives, on mange des merles ). Mais le con...il me fait le même cinéma a quelque chose prés...donc, je suis perplexe.

Je me tourne vers le "appcompat.txt"...A priori, y'a des choses interressantes de ce côté...

12

Bon, alors, le "appcompat.txt"...ne contient que des précisions sur le rapport d'erreur.

Par contre, c'est indéchiffrable pour moi:


TABASE>
<EXE NAME="Civilization3.exe" FILTER="GRABMI_FILTER_PRIVACY">
<MATCHING_FILE NAME="Civilization3.exe" SIZE="1499590" CHECKSUM="0xC7BB7331" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="02/01/2002 20:45:10" UPTO_LINK_DATE="02/01/2002 20:45:10" />
<MATCHING_FILE NAME="Civ3Edit.exe" SIZE="1040384" CHECKSUM="0x74D5C36A" BIN_FILE_VERSION="1.11.0.1" BIN_PRODUCT_VERSION="1.14.0.1" PRODUCT_VERSION="1.14f" FILE_DESCRIPTION="Civ3Edit MFC Application" COMPANY_NAME="FIRAXIS Games, Inc." PRODUCT_NAME="Civ3Edit Application" FILE_VERSION="1.11" ORIGINAL_FILENAME="Civ3Edit.EXE" INTERNAL_NAME="Civ3Edit" LEGAL_COPYRIGHT="Copyright (C) 2001 FIRAXIS Games, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x4" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.11.0.1" UPTO_BIN_PRODUCT_VERSION="1.14.0.1" LINK_DATE="12/21/2001 16:07:07" UPTO_LINK_DATE="12/21/2001 16:07:07" VER_LANGUAGE="Français (France) [0x40c]" />
<MATCHING_FILE NAME="binkw32.dll" SIZE="291328" CHECKSUM="0x2C07AE17" BIN_FILE_VERSION="1.0.22.0" BIN_PRODUCT_VERSION="1.0.22.0" PRODUCT_VERSION="1.0w" FILE_DESCRIPTION="RAD Video Tools" COMPANY_NAME="RAD Game Tools, Inc." PRODUCT_NAME="Bink and Smacker" FILE_VERSION="1.0w" LEGAL_COPYRIGHT="Copyright (C) 1994-2000, RAD Game Tools, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x0" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="1.0.22.0" UPTO_BIN_PRODUCT_VERSION="1.0.22.0" LINK_DATE="12/03/2000 02:38:18" UPTO_LINK_DATE="12/03/2000 02:38:18" />
<MATCHING_FILE NAME="Mss32.dll" SIZE="346624" CHECKSUM="0xBC80188F" BIN_FILE_VERSION="3.0.0.0" BIN_PRODUCT_VERSION="3.0.0.0" PRODUCT_VERSION="6.1a" FILE_DESCRIPTION="Miles Sound System" COMPANY_NAME="RAD Game Tools, Inc." PRODUCT_NAME="Miles Sound System" FILE_VERSION="6.1a" LEGAL_COPYRIGHT="Copyright (C) 1991-2001, RAD Game Tools, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x0" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x57DAE" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="3.0.0.0" UPTO_BIN_PRODUCT_VERSION="3.0.0.0" LINK_DATE="03/31/2001 19:41:24" UPTO_LINK_DATE="03/31/2001 19:41:24" />
<MATCHING_FILE NAME="sound.dll" SIZE="454656" CHECKSUM="0x1FB39656" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="09/28/2001 19:12:58" UPTO_LINK_DATE="09/28/2001 19:12:58" />
<MATCHING_FILE NAME="jgl.dll" SIZE="405504" CHECKSUM="0x988C1E7C" MODULE_TYPE="WIN32" PE_CHECKSUM="0x0" LINKER_VERSION="0x0" LINK_DATE="11/26/2001 16:34:47" UPTO_LINK_DATE="11/26/2001 16:34:47" />
<MATCHING_FILE NAME="redist\win32\Mss32.dll" SIZE="346624" CHECKSUM="0xBC80188F" BIN_FILE_VERSION="3.0.0.0" BIN_PRODUCT_VERSION="3.0.0.0" PRODUCT_VERSION="6.1a" FILE_DESCRIPTION="Miles Sound System" COMPANY_NAME="RAD Game Tools, Inc." PRODUCT_NAME="Miles Sound System" FILE_VERSION="6.1a" LEGAL_COPYRIGHT="Copyright (C) 1991-2001, RAD Game Tools, Inc." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x0" VERFILETYPE="0x1" MODULE_TYPE="WIN32" PE_CHECKSUM="0x57DAE" LINKER_VERSION="0x0" UPTO_BIN_FILE_VERSION="3.0.0.0" UPTO_BIN_PRODUCT_VERSION="3.0.0.0" LINK_DATE="03/31/2001 19:41:24" UPTO_LINK_DATE="03/31/2001 19:41:24" />
</EXE>
<EXE NAME="ntdll.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="ntdll.dll" SIZE="699392" CHECKSUM="0xF35B16B7" BIN_FILE_VERSION="5.1.2600.0" BIN_PRODUCT_VERSION="5.1.2600.0" PRODUCT_VERSION="5.1.2600.0" FILE_DESCRIPTION="DLL Couche NT" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Système d'exploitation Microsoft® Windows®" FILE_VERSION="5.1.2600.0 (xpclient.010817-1148)" ORIGINAL_FILENAME="ntdll.dll" INTERNAL_NAME="ntdll.dll" LEGAL_COPYRIGHT="© Microsoft Corporation. Tous droits réservés." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xB2765" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.0" UPTO_BIN_PRODUCT_VERSION="5.1.2600.0" LINK_DATE="08/23/2001 16:43:57" UPTO_LINK_DATE="08/23/2001 16:43:57" VER_LANGUAGE="Français (France) [0x40c]" />
</EXE>
<EXE NAME="kernel32.dll" FILTER="GRABMI_FILTER_THISFILEONLY">
<MATCHING_FILE NAME="kernel32.dll" SIZE="991744" CHECKSUM="0xC6EDB17B" BIN_FILE_VERSION="5.1.2600.0" BIN_PRODUCT_VERSION="5.1.2600.0" PRODUCT_VERSION="5.1.2600.0" FILE_DESCRIPTION="DLL du client API BASE Windows NT" COMPANY_NAME="Microsoft Corporation" PRODUCT_NAME="Système d'exploitation Microsoft® Windows®" FILE_VERSION="5.1.2600.0 (xpclient.010817-1148)" ORIGINAL_FILENAME="kernel32" INTERNAL_NAME="kernel32" LEGAL_COPYRIGHT="© Microsoft Corporation. Tous droits réservés." VERFILEDATEHI="0x0" VERFILEDATELO="0x0" VERFILEOS="0x40004" VERFILETYPE="0x2" MODULE_TYPE="WIN32" PE_CHECKSUM="0xF635B" LINKER_VERSION="0x50001" UPTO_BIN_FILE_VERSION="5.1.2600.0" UPTO_BIN_PRODUCT_VERSION="5.1.2600.0" LINK_DATE="08/23/2001 16:43:58" UPTO_LINK_DATE="08/23/2001 16:43:58" VER_LANGUAGE="Français (France) [0x40c]" />
</EXE>
</DATABASE>

Donc, je ne suis pas plus avancé...

Je me demande si il ne faudrait pas que l'essaie avec un autre civIII.exe, si quelqu'un veut bien me l'envoyer...




13

Bon...


Des nouvelles du front...


CA MARCHE!!!!

Hourraaah!!! Victoire!!!!

Et beh, c'était moins évident qu'une partie!!!

Alors, en fait, j'ai réinstallé civ3 avec le patch. Puis, j'ai installé le service pack2 de winXP! lol

Du coup ça tourne nikel!!!


Merci de vos conseils etc, et longues parties de civ!!! wink

14

Bah cool et bravo, parce que les infos des rapports d'erreur n'aident en rien.
avatar

15

Ouais....vive windows!!!