Posté le 27/05/2008 à 13:52 Membre depuis le 12/02/2007, 75 messages
Salut tout le monde!
Je viens de mettre ION sur ma TI 83+ ; je ne sais pas d'où vient ce problème, mais l'écran s'affiche en diagonale ; ce qui veut dire qu'au coin en bas à droite, c'est le haut de l'écran qui est affiché ; de même pour la plupart de tous les jeux ; ainsi, dans smario , mario ne se déplace pas sur du plat, mais monte perpétuellement un escalier ; quand on saute, on peut des fois voir sa tête au bas de l'écran apparaître, pour ensuite disparaître, quand Mario retombe...
JE ne sais pas d'où vient ce problème, mais je rencontre le même avec mirages OS...
Aidez moi, SVP!
Posté le 27/05/2008 à 17:52 Membre depuis le 11/04/2007, 1076 messages
Au choix, faut installer la dernière version de l'OS ou c'est pas réparable...
Posté le 28/05/2008 à 19:17 Membre depuis le 21/08/2006, 73 messages
J'ai eu le meme probleme en jouant a Mario sur TI-82...

D'habitude il n'y pas de probleme, mais avec des piles neuves, le CPU est legerement plus rapide, et c'est ca qui pose probleme...

En fait ca viens de la routine d'affichage de l'ecran sous ION qui est un peu trop rapide pour le driver LCD: le programme ecrit des donnees et le driver n'arrive pas a suivre, d'ou l'ecran "en escalier".

Le seul moyen de resoudre le probleme est de mettre des piles un peu plus vieilles (ou d'user volontairement tes piles en laissant allume ta calto).

Si tu ne vient pas de changer tes piles, alors je sais pas...
Posté le 02/06/2008 à 09:32 Membre depuis le 12/02/2007, 75 messages
Je ne pense pas que àa vienne de là, sérieusement!!!
Pour l'os, j'ai installé le 1.19 ; j'avais le 1.17, avant et j'avais aussi ce problème!!!

Cette histoire de piles ne tient pas non plus parce que je viens de les changer, et j'avais également le même problème...

J'ai fait un MEM reset, et ça n'a rien changé...

Ce qui m'étonne, c'est que l'application Bubble fonctionne parfaitement ; je sais que je n'ai pas besoin de Ion pour la faire fonctionner, mais ça m'étonne quand même...

Est-ce que vous pourriez me poster un lien vers la version de Ion que vous avez téléchargé?Bien que ce soit improbable, ça pourrait peut-être être dû au fait que j'aurais téléchjarger une version de merde, avec la chance que j'ai, des fois...

Sinon, une autre question ; est ce que savez comment convertir des images .bmp en .z80?
Parce que j'ai un vieil ordi tout pourri (win 98, respects, SVP top ), et le format pcx n'est pas pris en compte, donc pic83, j'y arrive pas...

Posté le 02/06/2008 à 09:41 Membre depuis le 15/03/2005, 3470 messages
Pourquoi tu veux du '.z80' ? Tu peux avoir directement du '.8xi' avec iView. Sinon je te conseil Image Studio 2.3.
Posté le 05/06/2008 à 09:49 Membre depuis le 12/02/2007, 75 messages
J'esssaye ; je te donne le résultat demain!
Merci bien pour les conseils!
Posté le 05/06/2008 à 09:51 Membre depuis le 12/02/2007, 75 messages
Si je veux du .z80, c'est pour pouvoir faire des sprites, ou des images de présentation de prgms ; c'est pour pouvoir intégrer l'image dans le programme!!
Posté le 19/08/2008 à 17:49 Membre depuis le 11/10/2004, 75 messages
Il y a un port qui permet de décaler l'écran verticalement.
Peut être qu'il y a une mauvais communication avec ce port là comme une micro-coupure qui fait qu'une mauvais commande est envoyée...

On peut faire des trucs assez amusant comme faire tourner une interruption qui décale de 1pxl vers le haut puis vers le bas, ça donne une impression de flou à l'écran mais si on éteint la calculatrice ça s'arrête.
Posté le 26/09/2008 à 18:51 Membre depuis le 24/08/2007, 729 messages
J'ai aussi ce problème d'écran en travers avec ion ; j'ai un écran de travers sur le menu prgmA, mais ensuite, quand je lance le jeu (phoenix en l'occurrence) l'écran est "droit". Cependant, je me souvien que avec une application qui utilisée aussi ion pour le lancement, l'écran était de travers pendant son exécution.
Perso, je pense que le probème est interne à la calto, certainement un problème de CPU qui va trop vite (j'avais lu sur un site que overclocker sa calculatrice pouvait avoir cet effet là)... Donc si on a ce problème on peut rien y faire... ou alors acheter une autre calto.
Mais sur tous les utilisateurs de TI83+ que je connais et qui utilisent ion, je dirais que 1/3 a ce problème...
Et ça ne peut pas être non plus un pb de piles neuvent ou pas (enfin, a part dans de rares cas où la vitesse du CPU est vraiment limite) car perso ça fait 3 ans que je me sers de ion, et j'ai tujours eu le problème, piles neuves comme vielles.
avatarloclamor
Mondo Photo
Le voyage en photo et en 1 clic
Posté le 26/09/2008 à 18:55 Membre depuis le 25/12/2006, 499 messages
Moi j'ai arrêté de chercher une réponse à ce problème, apparemment il n'existe pas de solution (du moins, sur 83+).
Posté le 26/09/2008 à 18:56 Membre depuis le 24/08/2007, 729 messages
c'est en gros ce que je disais aussi ; et pis osef, phoenix fonctionne correctement, c'est ça le principal, non ? ^^
avatarloclamor
Mondo Photo
Le voyage en photo et en 1 clic
Posté le 26/09/2008 à 19:06 Membre depuis le 25/12/2006, 499 messages
phoenix ?
Posté le 26/09/2008 à 19:17 Membre depuis le 24/08/2007, 729 messages
avatarloclamor
Mondo Photo
Le voyage en photo et en 1 clic
Posté le 26/09/2008 à 19:17 Membre depuis le 25/12/2006, 499 messages
C'est quoi ?
Posté le 26/09/2008 à 19:25 Membre depuis le 24/08/2007, 729 messages
un jeu... t'es un p'ti vaisseau, et tu "nettoie" l'écran pour finir le niveau, puis le jeu. Fonctionne avec ion.
avatarloclamor
Mondo Photo
Le voyage en photo et en 1 clic
Posté le 26/09/2008 à 19:25 Membre depuis le 15/03/2005, 3470 messages
Le problème est due au fait que la routine d'affichage est trop rapide pour le driver LCD je croit, mais il n'existe pas vraiment de solution pour le moment (il faudrait adapter le patch 84+ vers la 83+ mais c'pas si simple).
Posté le 26/09/2008 à 19:26 Membre depuis le 25/12/2006, 499 messages
Ok, aucun intérêt pour mon problème alors.
Posté le 30/10/2009 à 22:06 Membre depuis le 30/10/2009, 10 messages
LA grande cause : l'overlock !!! fou
Vous auriez pas touche a une résistance ( R4 je crois ^^ roll )
il m'est arrive la même chose avec ma ti 83, et l'écran s'est mis tout seul de travers (super quand tu joue a falldown !! rage )
ben il suffit tt simplement de nettoyer TOUTS hum hum le composants de la ti et pis ca doit repartir!!!

EDIT:
ben sinon tu t'amuse a merder dans le code source et tu change touts les
call ionFastCopy par des bcall(_grbufcpy) fou

bon euh je sais je deterre un peu le sujet , mais ca peut en aider !!! happy
Posté le 31/10/2009 à 12:58 Membre depuis le 24/08/2007, 729 messages
Perso j'ai pas touché aux résistances, le problème est d'origine...

Pis j'ai pas envie de "merder le code source" comme tu dis :P

Et j'ai pris l'habitude de falldown "penché", ça me gênerai si il se retrouvait "droit" tongue

Sinon, joli UP wink
avatarloclamor
Mondo Photo
Le voyage en photo et en 1 clic