Posté le 20/07/2014 à 23:44 Membre depuis le 12/02/2012, 4977 messages
oeuf course smile
meme si là j'ai une Sony KDLmachintrucABAEP qui supporte bien le ST via la peritel, ça serait sympa.
y'avait pas un gars sur atari-forum qui bossait sur ça?
Posté le 21/07/2014 à 00:38 Membre depuis le 16/12/2007, 919 messages
Je ne sais pas, si tu as un lien... Pour ma part j'ai bossé une semaine en tripotant un STE. J'ai un téléviseur 104cm philips qui refusait obstinément d'afficher l'image d'un St ou de la jaguar. Enfin il l'affichait par intermittence... Mais là ça marche et sans trop modifier le ST qui reste compatible avec d'autres télé retro. Je prépare un billet pour faire le point là dessus.
Posté le 21/07/2014 à 10:14 Membre depuis le 08/05/2008, 628 messages
Ca attise ma curiosité (les yeux qui s'ébouriffent comme aurait dit l'autre...)... Mais quoi qu'est-ce ? smile Vais-je devoir poubelliser mon installation ? tongue
Posté le 21/07/2014 à 12:11 Membre depuis le 16/12/2007, 919 messages
he he ! je rédige mon article, ça devrait t'interesser. Mais dire que tu devras poubeliser ton installation, je ne sais pas... Quelle est elle ?
Posté le 21/07/2014 à 13:07 Membre depuis le 12/02/2012, 4977 messages
Si c'est pas trop complexe à faire, je serai intéressé.
Posté le 21/07/2014 à 14:22 Membre depuis le 16/12/2007, 919 messages
Non c'est simple (relativement). Il faudra tout de même jouer du fer à souder.
Posté le 21/07/2014 à 16:56 Membre depuis le 16/12/2007, 919 messages
C'est à fignoler, mais c'est en ligne. j'attends vos retours les amis. tv
Posté le 21/07/2014 à 17:29 Membre depuis le 27/04/2006, 60457 messages
Ouais ben c'est l'un des points corrigés par le montage dans le post ./61... il y en a d'autres tongue

Et la sortie 12V de la prise vidéo du ST est limitée en courant, tu es sûr que tu as la bonne tension derrière ton régulateur ?
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 21/07/2014 à 17:47 Membre depuis le 16/12/2007, 919 messages
Un des points corrigé dans le post dont du donne le lien. Celui-ci donc aujourd'hui... tongue
La sortie vidéo du ST est limitée en courant en effet. As tu lu l'article en entier ?
J'ai 5v mais le décodeur du convertisseur et du téléviseur l'acceptent sans problème.
Ceci dit on peut envisager un pont de résistance en sortie pour obtenir du 3v pour être iso, mais ça a peu d’intérêt.
Posté le 21/07/2014 à 18:16 Membre depuis le 08/05/2008, 628 messages
@LaBibleAtari, mon install est hors concours en tarif, rien à voir avec une bidouille puisque j'ai un xrgb-3. Non, ici le but n'est pas le même mais ça a le mérite d'être abordable ! wink
Posté le 21/07/2014 à 18:55 Membre depuis le 16/12/2007, 919 messages
Belle bête en effet! mais pour l'atariste non fortuné je pense que ma bidouille sera en effet plus abordable wink
Posté le 21/07/2014 à 21:16 Membre depuis le 08/05/2008, 628 messages
J'en suis sûr ! J'ai d'autres besoins, il n'empêche que j'applaudis des deux mains ces bidouilles qui apportent un mieux pour nos machines !
Posté le 21/07/2014 à 21:20 Membre depuis le 27/04/2006, 60457 messages
./98 > le prend pas mal, mais tu as juste redécouvert un truc que j'avais déjà posté, et ce n'est qu'une partie du puzzle tongue

De plus, tu n'as pas besoin d'autant de composants : la tension de sortie est connue, l'impédance de sortie et celle d'entrée le sont aussi, donc il suffit d'une simple résistance en tout et pour tout (je l'ai pas fait sur le schéma parce qu'il fallait de toute façon du 5V pour alimenter le circuit qui refait la synchro composite, et il n'y a pas assez de courant sur la sortie 12V pour ça)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 21/07/2014 à 22:01 Membre depuis le 16/12/2007, 919 messages
Je ne le prends pas mal Zerosquare, mais Il me semble que tu n'as pas lu l'article sur la fin.
J'ai testé le montage avec la simple résistance entre la commutation lente et rapide, mais ça ne marche pas. Au pire l’écran continue de basculer entre vidéo-composite et synchro-composite, au mieux l'image est horrible. L'avantage de mon montage est qu'il approche au plus prêt les tensions attendues de la norme est du téléviseur pour les deux signaux de commutation, ce qui le rend plus stable et j'imagine plus compatible pour les différentes marques de téléviseur.
Attendons les retours, s'il y en a. Pour le manque de courant du 12v sur la broche du ST, j'y remédie à la fin de l'article en changeant une résistance dans le ST et le tour est joué. Le changement de cette résistance dans le ST ne change pas la compatibilité du ST avec un câble non modifié et le ST se comporte de la même manière qu'avant et alimente correctement le montage d'un câble modifié. J'ai cherché et expérimenté mon montage plusieurs fois et sur trois télés avant de vous en parler et franchement je pense que c'est une bonne solution même si on peut peaufiner. Il nécessite peu de modification du ST et s’intègre facilement au câble péritel.
Mais je ne remets pas en cause tes propres recherches et pour être en accord avec ta devise, mon résultat est l'aboutissement de recherches qui s'inspire des réussites et des échecs de beaucoup de personnes. Ce qui compte c'est le résultat et pour ma part, il est là wink
Posté le 21/07/2014 à 22:06 Membre depuis le 27/07/2004, 6556 messages
Personne ne le prend mal, vous inquietez pas, ici il y a des vrais Ataristes, et par 'héritage du :

Stay cool, Stay Atari vous etes cool, donc pas de soucis smile



GT #bisous#
avatar< SCPCD > j'aurais du dire "les doigts dans le cul vu que le java c'est de la merde"
Je suis Goto !
Posté le 21/07/2014 à 22:28 Membre depuis le 16/12/2007, 919 messages
Je ne le prends pas mal wink
mais il me semble que c'est une amélioration notable de l'évolution du ST qui peut être utile à pas mal de personne vu que ça marche vraiment chinois
Posté le 21/07/2014 à 22:43 Membre depuis le 27/07/2004, 6556 messages
Je connais Zero plutot bien, il est le premier a donner des infos a titre gratuit, surtout si cela peux aider des personnes. Certaines personnes sur ebay et Atariage ont mis sa tete a prix a cause de cela, il leur a cassé le marché 'juteux' de la Jaguar. Il voulait juste t'éviter de refaire une chose qu'il a deja essayé. Je sais bien qu'il y a pas de soucis smile



GT wink
avatar< SCPCD > j'aurais du dire "les doigts dans le cul vu que le java c'est de la merde"
Je suis Goto !
Posté le 21/07/2014 à 22:50 Membre depuis le 16/12/2007, 919 messages
Je n'en veux pas à Zérosquare, je sais que son avis est précieux. Il me semble juste qu'il n'a pas lu jusqu'au bout mon article. En outre j'ai bien sur essayé ce qu'il recommande, mais ça ne fonctionne pas. Mon montage si...
J'avoue que l'idée d'avoir ma tête mise à prix a côté de celle de Zero, me gonfle d'orgueil wink
Posté le 21/07/2014 à 23:04 Membre depuis le 27/07/2004, 6556 messages
LabibleATARI (./107) :
Je n'en veux pas à Zérosquare, je sais que son avis est précieux. Il me semble juste qu'il n'a pas lu jusqu'au bout mon article. En outre j'ai bien sur essayé ce qu'il recommande, mais ça ne fonctionne pas. Mon montage si...
J'avoue que l'idée d'avoir ma tête mise à prix a côté de celle de Zero, me gonfle d'orgueil wink


lol


GT rotfl
avatar< SCPCD > j'aurais du dire "les doigts dans le cul vu que le java c'est de la merde"
Je suis Goto !
Posté le 21/07/2014 à 23:26 Membre depuis le 27/04/2006, 60457 messages
smile

Oui je n'avais pas vu le paragraphe sur la résistance, désolé (j'ai lu un peu en diagonale).

Mais il y a quand même des trucs étranges sur ton schéma : les valeurs de résistance ne correspondent pas entre les photos et le texte, et la sortie du régulateur est en court-circuit avec la masse.

D'autre part, d'après quelques calculs rapides, il y a un truc qui cloche : ça ne donne pas les bonnes valeurs de tension, et avec une résistance de 470 ohms dans le ST, il n'y a de toute façon aucune combinaison de valeurs qui peut marcher. Mais je vérifie avec un simulateur pour voir si je ne raconte pas de conneries.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 00:19 Membre depuis le 16/12/2007, 919 messages
Yep ! tu as raison le schéma est à modifier. En effet la sortie n'a rien à faire sur la masse, je vais corriger ça. Et seconde erreur, dans le texte je note que j'ai mis une resistance de 100ohm alors que c'est 75ohm... Merci d'avoir relevé les incohérences. Ceci dit ça marche.
Second test effectué ce soir avec un méga STE sur lequel j'ai fait la modification : image ne saute plus et est nickel sur le convertisseur hdmi. Par contre sur la péritel du téléviseur l'image bave un peu comme avec le STE. Je suis ouvert à toute suggestion. Je pense que pour l'image un peu baveuse, le montage avec les portes logiques à la place du transistor du ST pour le signal de synchro, celui-ci serait plus carré et aurait plus de punch pour le décodeur du téléviseur...
Posté le 22/07/2014 à 00:58 Membre depuis le 27/04/2006, 60457 messages
Ce n'est pas parce que ça sembler marcher que ça marchera partout et dans tous les cas smile

La tension sur la broche 8 doit être comprise entre 9.5 et 12 V pour une image en 4:3.
La tension sur la broche 16 doit être comprise entre 1 et 3 V.

J'ai simulé ton schéma, voilà ce que ça donne :
QJ1U
R1 est la résistance en série avec le 12 V dans le ST.
R2 et R3 sont les deux résistance de ton montage.
R4 est la résistance qui est reliée entre la broche 16 et la masse à l'intérieur du téléviseur.

Déjà, le régulateur 5 volts ne fonctionne pas correctement : il ne sort que 2.07 V.
Pour la broche 16 (1.09 V) c'est OK, bien que proche de la limite inférieure (et avec les tolérances des résistances, ça peut être limite).
Pour la broche 8 (4.48 V) par contre, c'est beaucoup trop bas : aucune garantie que le téléviseur commute bien. De plus, sur les téléviseurs compatibles 16:9, une tension entre 4.5 V et 7 V active le mode 16:9, donc l'image du ST sera étirée.

Avec deux résistances de 75 ohms au lieu de 22 et 68 ohms, ça ne marche pas non plus (c'est même légèrement pire) :
hnlG

Comme je te le disais, il y a plus simple : il suffit de remplacer la résistance dans le ST par une 75 ohms, et de mettre une résistance de 330 ohms entre la broche 8 et la broche 16 :
pDy8
Comme ça toute les tensions sont bonnes, et ça fait pas mal de composants en moins smile
(note : la résistance de 330 ohms chauffe un peu, c'est normal)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 01:03 Membre depuis le 27/04/2006, 60457 messages
Pour l'image baveuse, essaie de rajouter les résistances série de 68 ohms sur les lignes R, G et B comme indiqué dans le post ./61. Les signaux du ST ont une tension trop élevée et certaines télés n'aiment pas, ça peut donner une images baveuse et/ou des couleurs trop claires qui saturent. Sinon ça peut venir de la télé aussi, pas mal de télés LCD ont une image qui bave un peu (voire beaucoup) même en RGB. Pas de solution à part utiliser un boîtier de conversion HDMI externe, malheureusement.

Pour la synchro, sur les ST qui ont un modulateur, le signal est propre et il n'y a pas besoin d'y toucher.
Pour les ST qui n'ont pas de modulateur, je recommande le montage du post ./61. Si c'est trop compliqué pour vous, rajoutez juste une résistance de 1 kohm en série avec le fil qui va à la broche 20. C'est moins bien mais certaines télés devraient s'en contenter.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 09:59 Membre depuis le 16/12/2007, 919 messages
Merci d'avoir pris le temps de te pencher sur ce cas d'étude Zero. J'ai corrigé mon schéma, mais ta solution finale ne semble pas conforme à la norme. Tu suggère de remplacer la résistance de 1,2k interne du ST par une résistance de 75ohm, ce qui est en dessous de la résistance de sortie de la norme (entre 300ohm et 1kohm). Ca peut être une source de danger pour le téléviseur si on branche un câble non modifié dans ce cas non ?
Posté le 22/07/2014 à 10:05 Membre depuis le 16/12/2007, 919 messages
Ceci dit les chiffres calculés ne correspondent pas tout à fait à ce que j'ai mesuré lors de mes tests ?!?
Posté le 22/07/2014 à 13:53 Membre depuis le 27/04/2006, 60457 messages
C'est une simulation, dans la pratique il y a toujours des variations d'un composant à l'autre. En plus le 78L05 existe chez plusieurs fabricants et il peut y avoir des différences. Mais ça ne change pas le fait qu'il y a un souci smile

Pour la résistance, effectivement c'est hors spéc, mais ce n'est pas dangereux pour le téléviseur. De toute façon, même en mettant la valeur la plus faible autorisée (300 ohms), tu n'auras pas assez de courant pour avoir à la fois un niveau valide sur la broche 8 et sur la broche 16.

Si ça t'empêche de dormir, met une résistance de 470 ohms dans le ST, débranche la broche 8 et branche directement la sortie sur la broche 16. Le téléviseur ne commutera plus automatiquement sur l'entrée AV, mais ce sera 100% conforme smile
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 14:08 Membre depuis le 16/12/2007, 919 messages
Ca ne m'empêche pas de dormir wink
Par contre tu sorts des clous de la norme encore en branchant directement le 12v sur la broche de la commutation rapide. Le signal d'entrée est de 1v nominal à 3v, on dépasse amplement là.
Je vais refaire les mesures et faire un tableau précis, mais de mémoire, j'avais 4,7v sur l'entrée de commutation rapide et 10,5v sur la commutation lente. Plus proche du résultat souhaité. Je regarde ça et je te dis. J'en profiterai pour voir si atténuer les signaux RVB, rend l'image moins baveuse. Merci pour tes conseils.
Posté le 22/07/2014 à 14:12 Membre depuis le 27/04/2006, 60457 messages
LabibleATARI (./116) :
Par contre tu sorts des clous de la norme encore en branchant directement le 12v sur la broche de la commutation rapide. Le signal d'entrée est de 1v nominal à 3v, on dépasse amplement là.
Non. La résistance de 470 ohms dans le ST et la résistance de 75 ohms dans le téléviseur forment un diviseur de tension. Si tu calcules tu verras que la tension obtenue est 1.65 V, donc dans les clous smile
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 14:37 Membre depuis le 16/12/2007, 919 messages
Tout juste auguste ! j'oublie la résistance interne au téléviseur. Soit 1.651v. Cette résistance est elle la même à l'entrée péritel de tous les téléviseurs ? Il ne faudrait pas que l'on confonde résistance et impédance... Je sais qu'on peut te faire confiance la dessus smile
Posté le 22/07/2014 à 14:43 Membre depuis le 27/04/2006, 60457 messages
Oui, c'est normalisé, pas de souci.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 22/07/2014 à 14:49 Membre depuis le 16/12/2007, 919 messages
Au fait ta tête est mise à prix à combien ?
rotfl