Posté le 30/07/2017 à 18:17 Membre depuis le 13/09/2007, 441 messages
Bonjour,

je très heureux de vous informer qu'après de long mois à dire que MyAES 0.97 allait sortir et bien c'est maintenant chose faite.

Je pense que c'est une belle version.

Toutes les informations sur : http://myaes.lutece.net

Olivier
Posté le 30/07/2017 à 18:50 Membre depuis le 04/06/2007, 556 messages
WOW !!!!

Je m'empresse de tester celà !

Chapeau bas Olivier !
Posté le 30/07/2017 à 19:19 Membre depuis le 16/08/2002, 1800 messages
grand merci
Posté le 31/07/2017 à 08:34 Membre depuis le 24/12/2016, 21 messages
Merci Oliver pour cette nouvelle version top
avatar
Posté le 31/07/2017 à 08:38 Membre depuis le 19/06/2012, 228 messages
Merci Olivier. C'est bon de voir MyAES avancer.
Posté le 01/08/2017 à 21:38 Membre depuis le 31/03/2006, 777 messages
super merci
je test après mon retour de vacances
Posté le 04/08/2017 à 11:42 Membre depuis le 04/12/2007, 1743 messages
Merci Olivier, je testerai aussi en rentrant. C'est cool que tu restes toujours actif.

Pour info j'ai la dernière version installée juste avant celle ci, et je rencontre un problème de clavier dans les jeux fenêtrés (chose qui avait été corrigé y'a 2-3 ans).
Par ex. tout simplement dans celui-ci on ne peut même pas déplacer le personnage :
http://peterlane.info/sokoban.html

Est ce que la dernière version corrige le problème?
Posté le 04/08/2017 à 18:01 Membre depuis le 04/01/2005, 952 messages
bravo pour ce projet et comme dit si bien Madmax2023, c'est cool que tu restes actif.
Posté le 04/08/2017 à 20:38 Membre depuis le 13/09/2007, 441 messages
MadMax2023 (./7) :
Merci Olivier, je testerai aussi en rentrant. C'est cool que tu restes toujours actif.

Pour info j'ai la dernière version installée juste avant celle ci, et je rencontre un problème de clavier dans les jeux fenêtrés (chose qui avait été corrigé y'a 2-3 ans).
Par ex. tout simplement dans celui-ci on ne peut même pas déplacer le personnage :
http://peterlane.info/sokoban.html

Est ce que la dernière version corrige le problème?

Salut MadMax contant d'avoir de tes nouvelles

Je ne sais pas, je viens de tester la version actuelle et chez moi je déplace très bien la boule bleu au clavier avec les flèches (j'ai testé Sako_ST.prg car sakoban.prg ne se lance pas (a moins que ce soit Mdesk qui me joue des tours!)).

Si ca ne va pas va falloir qu'on comprenne ce qu'il se passe parce que je ne me rappelle pas du tout de cela (ce n'est pas beau la vieillesses!)

Olivier
Posté le 04/08/2017 à 20:40 Membre depuis le 13/09/2007, 441 messages
vicomte (./8) :
bravo pour ce projet et comme dit si bien Madmax2023, c'est cool que tu restes actif.


Merci à vous tous, tant que je peux et que j'ai quelque chose à y mettre alors je continue!

Olivier
Posté le 06/08/2017 à 22:11 Membre depuis le 04/12/2007, 1743 messages
D'accord wink
À mon retour je mettrai à jour myaes avec la nouvelle version. Avec la précédente le personnage ne bouge pas du tout chez moi avec le clavier. À voir aussi si dans mon fichier de config de myaes j'ai pas de ligne obsolète pour la réactivité du clavier (ça me dit qq chose).
Posté le 07/08/2017 à 11:29 Membre depuis le 10/04/2012, 256 messages
Bravo et merci pour ton travail à mon retour de vacances je l essaie
Posté le 15/08/2017 à 23:09 Membre depuis le 04/12/2007, 1743 messages
J'ai installé myaes 0.97 en rentrant de vacances, mais je dois dire que je ne suis pas très chanceux avec.
Il a fallu que je rétrograde d'urgence à la 0.96 que j'utilise jusqu'alors et qui semble beaucoup plus adapté à mon système (stable et performant).

Au passage je confirme mon soucis de réactivité clavier que ce soit sur Sokoban (aucune réaction) ou jeux SDL (quelques mouvements possibles assez péniblement mais pas assez pour y jouer).
Posté le 16/08/2017 à 20:04 Membre depuis le 13/09/2007, 441 messages
MadMax2023 (./13) :
J'ai installé myaes 0.97 en rentrant de vacances, mais je dois dire que je ne suis pas très chanceux avec.
Il a fallu que je rétrograde d'urgence à la 0.96 que j'utilise jusqu'alors et qui semble beaucoup plus adapté à mon système (stable et performant).

Au passage je confirme mon soucis de réactivité clavier que ce soit sur Sokoban (aucune réaction) ou jeux SDL (quelques mouvements possibles assez péniblement mais pas assez pour y jouer).

Alors là je suis surpris, je pense que le soucis est dans la configuration pour les jeux SDL, si tu n'utilises pas les jeux que j'ai moi même compilé
http://ol.lutece.net/
tu peux tester scummvm, faudrait que je mette doom.

Bon la solution c'est de mettre l'option app_game_kbd suivi du nom du programme

exemple

app_game_kbd HEXEN

Devrait rentrer dans l'ordre sinon on tachera de comprendre pourquoi en privé.

Olivier
Posté le 23/08/2017 à 23:21 Membre depuis le 13/09/2007, 441 messages
Bonjour à tous

Ca y est un nouveau patch vient de sortir fallait s'y attendre!

Mauvais report de fonctionnement sur CT60, j'ai fixé divers bugs, réussi à recompiler MyAES avec PureC qui donne un résultat stable avec la CT60 (je ne vois pas ce qui ne va pas lié à GCC alors que le même kernel fonctionne très bien sur un TT ou un Milan!)

Tout cela est sur mon site, il y a une archive avec seulement les binaires, c'est moins gros!

Olivier
Posté le 24/08/2017 à 01:39 Membre depuis le 04/06/2007, 556 messages
J'ai installé la version 0.97 aujourd'hui, mais il faut que fasse encore des tests plus poussés, car pour le moment, il n'aime pas vraiment THING, pleins de pb de redraw, plantages/bloquage d'Aranym, alors qu'avec TERADESK c'est beaucoup mieux... DOOM fait quand à lui carrément sauter brutalement Aranym, avec un joli retour Winows en 1 fraction de seconde... J'ai bien mis APP_FORCEDESK pour thing...

Je vais continuer mes investigations....wink
Posté le 24/08/2017 à 20:42 Membre depuis le 13/09/2007, 441 messages
Playmobil (./16) :
J'ai installé la version 0.97 aujourd'hui, mais il faut que fasse encore des tests plus poussés, car pour le moment, il n'aime pas vraiment THING, pleins de pb de redraw, plantages/bloquage d'Aranym, alors qu'avec TERADESK c'est beaucoup mieux... DOOM fait quand à lui carrément sauter brutalement Aranym, avec un joli retour Winows en 1 fraction de seconde... J'ai bien mis APP_FORCEDESK pour thing...

Je vais continuer mes investigations....wink
Le dernier patch? GCC ou PureC?

Olivier
Posté le 09/09/2017 à 14:37 Membre depuis le 13/09/2007, 441 messages
Bonjour à tous

Je viens de casser les dents à plusieurs beaux bugs, pour ceux qui utilisent la 0.97 il est préférable de mettre à jours.

le patch est ici

http://myaes.lutece.net/telechargement/patch097.zip

Olivier
Posté le 09/09/2017 à 15:11 Membre depuis le 04/06/2007, 556 messages
OL (./18) :
Bonjour à tous

Je viens de casser les dents à plusieurs beaux bugs, pour ceux qui utilisent la 0.97 il est préférable de mettre à jours.

Comme moi avec NVDI ! lol

Je vais tester, mais j'ai toujours mon problème clavier...

Et question bête, J'ai un de mes programme qui ne fonctionne pas sous MYAES, mais pourtant fonctionne très bien sous XAAES...
La partie qui merdouille, c'est le Reboot/ShutDown...

J'utilise les fonctions GEMDOS SSync et Shutdown, donc 336 et 337 ==> http://toshyp.atari.org/en/00500e.html

No problémo sous XaAES, mais sous MyAES, ça me fige tout mon Aranym...
Posté le 09/09/2017 à 19:36 Membre depuis le 13/09/2007, 441 messages
Playmobil (./19) :
OL (./18) :
Bonjour à tous

Je viens de casser les dents à plusieurs beaux bugs, pour ceux qui utilisent la 0.97 il est préférable de mettre à jours.

Comme moi avec NVDI ! lol

Je vais tester, mais j'ai toujours mon problème clavier...

Et question bête, J'ai un de mes programme qui ne fonctionne pas sous MYAES, mais pourtant fonctionne très bien sous XAAES...
La partie qui merdouille, c'est le Reboot/ShutDown...

J'utilise les fonctions GEMDOS SSync et Shutdown, donc 336 et 337 ==> http://toshyp.atari.org/en/00500e.html

No problémo sous XaAES, mais sous MyAES, ça me fige tout mon Aranym...

Tu fais bien compliqué pour quelque chose de très simple, sans doute MyAES ne gére pas le signal du shutdown de Mint qui lui permettrait de temporiser je pense, mais la bonne solution est simplement d'utiliser shel_write() pour faire le shutdown, voici le code simplissime de mon programme gemhalt:

#include <stdio.h>
#include <gem.h>
void main()
{ int button;
appl_init();
button=form_alert(1,"[3][SHUTDOWN option][Abort|Reboot|Poweroff]");
if (button > 1) shel_write(SWM_SHUTDOWN,0, button-1,NULL, NULL);
appl_exit();
}
Posté le 13/09/2017 à 22:54 Membre depuis le 13/09/2007, 441 messages
OL (./18) :
Bonjour à tous

Je viens de casser les dents à plusieurs beaux bugs, pour ceux qui utilisent la 0.97 il est préférable de mettre à jours.

le patch est ici

http://myaes.lutece.net/telechargement/patch097.zip

Olivier
Encore une mise à jours ce soir pour d'affreux bugs bien planqués au chaud.

fichier mis à jours

Olivier
Posté le 14/09/2017 à 13:25 Membre depuis le 04/06/2007, 556 messages
Je vais tester ! (je sais je dit ça tout le temps ! grin)

Tu as jeté un oeil pour le problème des claviers sans pavé numérique sous MyAES ?

Car j'ai testé sous XaAes, et la bidouille avec CAPSLOCK fonctionne, bon je dit bidouille, car la frappe n'est plus du tout naturelle, mais je pense qu'on s'y habitue assez vite...




EDIT : Je viens de DL l'archive, je décompact sur mon C: et plusieurs fichiers ne respectent pas le format 8.3 ! bigeyes
Beaucoup de .PNG pas trop grave je me dit, mais 1 .LDG qui doit sûrement être important !
Posté le 14/09/2017 à 21:14 Membre depuis le 13/09/2007, 441 messages
Playmobil (./22) :
Je vais tester ! (je sais je dit ça tout le temps ! grin)

Tu as jeté un oeil pour le problème des claviers sans pavé numérique sous MyAES ?

Car j'ai testé sous XaAes, et la bidouille avec CAPSLOCK fonctionne, bon je dit bidouille, car la frappe n'est plus du tout naturelle, mais je pense qu'on s'y habitue assez vite...




EDIT : Je viens de DL l'archive, je décompact sur mon C: et plusieurs fichiers ne respectent pas le format 8.3 ! bigeyes
Beaucoup de .PNG pas trop grave je me dit, mais 1 .LDG qui doit sûrement être important !

Ah oui effectivement dans le windframe le dossier est trop long et il y a un dwidgetsPC.ldg qui n'a rien à faire là à éliminer.

Par contre est que cela fonctionne Guillaume me dit qu'il ne lance plus les programmes!

Purée j'en bave!

Olivier
Posté le 14/09/2017 à 21:40 Membre depuis le 04/06/2007, 556 messages
Bha, j'ai éssayé de contourner le problème en mettant MYaEs sur F: qui accepte les fichiers long, mais MyAES va toujours chercher le myAes.cnf sur C:

Donc pour le moment je suis un peu bloqué... Et ma version 0.96 est bourré de merde, mais là ça viens de chez moi, je suis en train d'adapter la Beekey sur Windows, et j'ai pas encore trop touché la partie MyAes...

Je vais attendre que tu nous reponde une énième version en full download pour tester correctement, mais je sais pas qui est Guillaume, mais moi tout mes programmes que je fais fonctionnent sous XaAes, mais pas MyAes, mais mes 3 derniers programmes sont fait avec les pieds LOL...

Haaa CHARVIEW ne fonctionne pas non plus, car j'essaie de résoudre ce satané pb de clavier... Charview se met bien dans YOPLA, mais pas de menu, même en drag&drop même combat... Rien ne se passe hormis l'icone dans Yopla

Yopla, bha il marche que si le desktop est au 1er plan chez moi...


Courage Olivier, MYAES vaut le coup !
Posté le 15/09/2017 à 07:22 Membre depuis le 13/09/2007, 441 messages
Playmobil (./24) :
Bha, j'ai éssayé de contourner le problème en mettant MYaEs sur F: qui accepte les fichiers long, mais MyAES va toujours chercher le myAes.cnf sur C:

Donc pour le moment je suis un peu bloqué... Et ma version 0.96 est bourré de merde, mais là ça viens de chez moi, je suis en train d'adapter la Beekey sur Windows, et j'ai pas encore trop touché la partie MyAes...

Je vais attendre que tu nous reponde une énième version en full download pour tester correctement, mais je sais pas qui est Guillaume, mais moi tout mes programmes que je fais fonctionnent sous XaAes, mais pas MyAes, mais mes 3 derniers programmes sont fait avec les pieds LOL...

Haaa CHARVIEW ne fonctionne pas non plus, car j'essaie de résoudre ce satané pb de clavier... Charview se met bien dans YOPLA, mais pas de menu, même en drag&drop même combat... Rien ne se passe hormis l'icone dans Yopla

Yopla, bha il marche que si le desktop est au 1er plan chez moi...


Courage Olivier, MYAES vaut le coup !
Pour lancer MyAES d'un autre disque que C, il faut mettre la variable d'environnement MYAES_PATH

MYAES_PATH=u:/e/gemsys/

Attention MyAES ne lance pas correctement toutes les applis sur un système de fichier ext2

Charview est malheureusement incompatible avec les nouvelles versions de Mint, faut que je mette le nez dedans,je pense qu'il faut que je désactive la possibilité de charger la table et la renvoyer directement au système.

Quels sont tes programmes? Je prend les trucs qui fonctionnent sous XaAES et pas sous MyAES sous Aranym surtout si l'auteur peut répondre à quelques réponses, c'est bien plus facile que de tenter de deviner ce qu'il se passe.

Cette 0.97 ce n'est pas encore le pied, trop de modifs!

Olivier
Posté le 15/09/2017 à 14:03 Membre depuis le 04/06/2007, 556 messages
Je referait quelques tests ce soir, mais de mémoire, y'a le programme de Daroou, Pupul_démo qui crash à la fin des initialisations...

Pour les miens, c'est des GUI pour PmDoom et POV, et un programme qui lance les images disquette soit sur STEEM soit sur Hatari selon le fomat de la disquette...

Sur mes programmes y'avait le shutdown/reboot qui ne fonctionne pas mais tu m'as donné la solution avec shel_write (qu'il faut que je test), mais surtout c'est l'affichage
des dialogues qui posent problème... Le cadre exterieur s'affiche, après il faut que je clique au hasard à l'interieur pour afficher les objets... Le form_Dial 3 ne fonctionne pas, et
si j'affiche un second dialogue, rien ne se passe...

Mais attention, je sais que mes programmes ne sont pas optimisé pour le moment, je n'ai pas ouvert d'écran virtuel workstation machin truc par exemple... Je te dirais quand j'aurai réglé ça...
Posté le 15/09/2017 à 17:24 Membre depuis le 04/06/2007, 556 messages
OL (./25) :

Pour lancer MyAES d'un autre disque que C, il faut mettre la variable d'environnement MYAES_PATH

MYAES_PATH=u:/e/gemsys/

Olivier

Heuuu, oui mais je le met où ça ??? Dans MyAES.CNF ? mais sur C: ou F: ??? MyAES est sur F: là, mais il prend les fichiers sur C:
Posté le 15/09/2017 à 17:53 Membre depuis le 24/12/2016, 21 messages
Dans mint.cnf peut-être:
setenv MYAES_PATH u:/f/gemsys/

Edit:
Pupul fonctionne correctement sur ma config (aranym 0.9.16 / MyAES097 GCC ou PureC, patch du 13/09)
avatar
Posté le 15/09/2017 à 19:02 Membre depuis le 04/06/2007, 556 messages
Les setenv c'est dans XaAes Daroou non ? J'ai pas le bon PC sous la main pour vérifier, pas avant ce soir....

Pupul chez moi fonctionne sous XaAes et MagiC, mais pas sous MyAES, mais comme dit, mon MyAES est pour le moment très très mal réglé ! fucktricol

Par contre il faut que ce soir j'aille refaire un tour sur ton site pour voir si les sources de Pupul sont dispo en GFA, car les utilisations des LDG m'interesse grandement !
Posté le 15/09/2017 à 19:29 Membre depuis le 24/12/2016, 21 messages
Nop, dans Mint.cnf wink

Edit: En fait, tu peux définir des variables d'environnement dans les deux fichiers. Mais pour MyAES, faut le définir dans mint.cnf, vu que tu charges pas XaAES.

Pupul chez moi fonctionne sous XaAes et MagiC, mais pas sous MyAES, mais comme dit, mon MyAES est pour le moment très très mal réglé ! fucktricol
Peut-être que la version debug peut aider (savoir déjà à quel endroit pupul plante)

Les sources sont en C smile
Par contre, l'archive MOD.LDG contient un source GFA pour l'utiliser.
avatar