Posté le 08/10/2005 à 13:49 Membre depuis le 08/10/2005, 6 messages
Bonjour tous le monde

Voila j'ai un problème je voudrait afficher les 1à variable en fonction d'un x défini dans l'affichage texte j'ai déja fait une partie du programme mais si la variable est vide j'avait une erreur donc j'ai mit zero dans les varaible vide et j'ai modifier mon programme pour qu'il ne mette pas les varaible étant a zero je pensez avoir résolut mon problème mais un peu plus tard je me suis dit que lorsqu'une des équation devrait être a zero normalement je ne pourrait pas la diffèrencier des variable dite vide! Si quelqu'un pouvait me dire comment différencier les variable vide dans un programme je l'en remercierais!

Datarok
Posté le 08/10/2005 à 16:04 Membre depuis le 09/07/2003, 21783 messages
heu, tu pourrais recomencer en plus claire et en plusieurs phrase ? grin. (tu veut un moyen de réper les variables utilisées et celles qui ne le sont pas ?)

Tu peut préciser ta calculette aussi wink.
Posté le 08/10/2005 à 21:39 Membre depuis le 08/10/2005, 6 messages
Oui voila c'est exactement sa!

J'ai une Ti 84 plus SE

Datarok
Posté le 08/10/2005 à 23:09 Membre depuis le 09/07/2003, 21783 messages
tu n'a pas déjà '0' dans les variable "vides" ? ( sur toutes les autres Ti z80 c'est comme ça.)
Donc si je ne dis pas de bétise, apr défault ces variables valent 0.
( tu pourais reporter l'erreur obtenue dans ton cas sinon ? )
Posté le 08/10/2005 à 23:18 Membre depuis le 08/10/2005, 6 messages
Non je n'es pas 0 dans les variables "vides"

Le message d'erreur est:
ERR: INVALID

Datarok

Merci d'avance
Posté le 08/10/2005 à 23:23 Membre depuis le 09/07/2003, 21783 messages
C'est que tu utilsie des variables spéciales, non ?
genre des Listtes, des valeur de graphique, etc..

( enfin, je n'ai pas de 84+, mais c'est normalement très proches des 83+....)
Quelle est ta variable ?
Posté le 08/10/2005 à 23:31 Membre depuis le 08/10/2005, 6 messages
Je te montre un des passage du programme ou l'erreur survient

If Y1=/=0
Then
Output(3,4,Y1)
Goto 1
Else

pour info =/= sa veux dire "différent de" je sait pas faire le égal barrer sur pc ^^

Voila sa bloque à l'affichage de la variable Y1

J'espère que tu pourra m'aider mais sinon merci quand même ^^

Datarok
Posté le 08/10/2005 à 23:33 Membre depuis le 08/10/2005, 6 messages
J'aurait du dire fonction au lieu de variable sa porte moins a confusion
Posté le 09/10/2005 à 10:05 Membre depuis le 09/07/2003, 21783 messages
Vi, t'utilise des variables non usuels. (quanbd on dit variable d'hab sur z80, c'est pour A-Z quoi hehe )

Hum, déjà poour afficher, je pense qu'utiliser Equ>Sring( porra t'être utile wink. [ equ>String(Yn,Str1) ]

Posté le 09/10/2005 à 17:06 Membre depuis le 08/10/2005, 6 messages
Oki je vien de voir ton message je vais essayez avec ce que tu me dit et on verra le résultat ^^

Merci beaucoup

Datarok