1

Hello,

Je finis un congé où j'ai pu bien bidouiller mon microserver NAS (pas autant que voulu mais déjà), et avec une grosse déception du dernier jour :
flecheMes 2x macos n'arrivent plus à résoudre "serveur.local" (mon serveur ayant un autre nom bien sûr).
Mon microserver tourne sous Openmediavault, qui est une Debian on ne peut plus à jour. Il y a des conteneurs Docker et un nginx qui fait reverse proxy (il m'en a fait baver...) et normalement, tout marche bien.
Depuis macos, le ping ne marche pas. Le nslookup répond (en non-authoritative). L'IP statique répond bien sûr. Je n'ai pas de serveur DNS, juste une box 4G qui fait serveur DHCP (mais mon serveur est en statique).

Et la cerise... la résolution fonctionne sous Windows. Damn !

Donc le pépin semble venir de mDNS/Zeroconf/Bonjour qui normalement se débrouille très bien pour trouver un nom DNS directement sur la machine elle-même. Mais plus depuis cet après-midi. Pourquoi ? confus
Ce que je ne comprends pas, c'est que ça marche depuis 4 mois... Ca a merdé une fois il y a 10 jours, puis ça c'est remis (j'avais mis ça sur le compte d'un reboot macos/reboot microserver, mais sans valider). Mais là, rien à faire. sad
Si cela dit quelque chose à un macqueux (ou à d'autres !), d'avance je vous en remercie, ça me rend marteau.fou


Et donc la continuité du topic, c'est : comment gérez-vous les DNS internes chez vous ? Avoir un serveur DNS me semble complètement overkill pour 2 ordis et un serveur... Mon microserver pourrait bien sûr le faire, mais je l'éteins la nuit !
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..

2

Et ce matin ça remarche.
Je comprends pas. Ca pourrait être le routeur (Huawei) après tout. Mais je l'avais aussi rebooté hier et ça marchait pas.

Bon pour ceux qui ont un brin d'infra chez vous, vous faites tous du DNS avec Raspberry PI ??
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..

3

Non, moi j'ai arrêté le DNS interne depuis le support d'IPv6 par tous mes terminaux (mais mon serveur est sur la DMZ, donc c'est sensiblement différent ; j'avais un souci de résolution nom <−> IPv4 interne/externe auparavant, mais IPv6 fait sauter ce souci donc j'attaque en interne mon serveur avec son nom public).
Sinon, c'est peut-être un souci lié à WINS si ça fonctionne sous Windows et pas sous MacOS ?
avatar

4

WINS, une piste, merci ! (Bon j'ai jamais vraiment su ce que c'était (je suis trop jeune ? gni C'est l'occasion de chercher un peu.)

IPv6 une autre solution ma foi, je vais étudier. C'est le 1er truc que j'ai désactivé sur OMV et Debian en l'installant gni Mais si ça semble utilisable (et mince, iptables en v6... snif) ça m'intéresse !
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..

5

WINS est le service de résolution de noms local de Windows, qui permet à une machine de prévenir qu'elle existe, avec un nom particulier. Sans serveur WINS, chaque machine broadcaste (avec plus ou moins de réussite). S'il y a un serveur WINS, il broadcaste en disant "JE SUIS LE SERVEUR WINS, DECLAREZ-VOUS À MOI OU INTERROGEZ-MOI !". Les clients font dont leurs requêtes directement auprès de lui.
De nombreux NAS font serveur WINS si l'option est validée, grâce aux services SaMBa. Windows Server avec un serveur DNS activé synchronise les informations DNS locales et WINS.
C'est le parfait exemple du service TGCM, mais qui peut rendre dingue quand ça merdoie.
(Contrairement à ce qu'indique la page WP française de WINS, les serveurs DNS Windows basés sur l'AD n'ont pas remplacé WINS qui reste le protocole de base pour tout ce qui est NetBIOS [le protocole d'échange d'informations des postes Windows entre eux])
avatar

6

Encore merci pour ton message, Nil. bisoo
J'ai évidemment pas eu le temps d'essayer quoi que ce soit cette semaine (reprise du boulot... avec 2 lardons xD) mais je viens juste de zieuter.
J'ai activé SMB sous OpenMediaVault (pour les partages) mais je vois que l'option WINS est désactivée. Comme les 2x principaux clients sont macos, je ne pense pas que ça ait un intérêt d'activer WINS, si ?

Dans les options SMB, il y a aussi "Allow this server to try and become a local master browser" qui est activé (je ne sais pas trop ce que ça veut dire confus), et le Workgroup est défini à "Workgroup" (classique, y'aurait-il mieux à faire ?).
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..

7

Nil (./3):
Sinon, c'est peut-être un souci lié à WINS si ça fonctionne sous Windows et pas sous MacOS ?
Du coup comme le serveur WINS était désactivé, c'est curieusement exactement le comportement inverse hum
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..

8

Je ne sais pas si macos comprend nativement wins, donc difficile à dire, pour le coup...
redangel (./6) :
Dans les options SMB, il y a aussi "Allow this server to try and become a local master browser" qui est activé (je ne sais pas trop ce que ça veut dire confus), et le Workgroup est défini à "Workgroup" (classique, y'aurait-il mieux à faire ?).
Quand un serveur SMB (Windows Serveur ou SaMBa), être Local Master Browser signifie que la machine sert de référence pour le "Voisinage réseau" dans l'univers Windows. Je ne sais pas si c'est (ou non) lié à WINS (théoriquement, il y a toutes les chances que ce soit le cas, mais peut être que ça utilise deux protocoles complémentaires).
avatar

9

Vu que je peux avoir l'option cochée alors que WINS est désactivé (le tout par défaut), je pense que ça ne doit pas être impérativement lié.

Pour macOS, oui WINS est supporté nativement : https://www.lifewire.com/configure-os-x-workgroup-name-mountain-lion-2260208
Me reste à vérifier mes options !
avatarL'homme qu'a vu l'homme qu'a vu l'ours, qu'a mangé l'facteur..