1
Bien le bonjour à tout le monde ! Je viens de m'inscrire sur le forum car j'ai un souci assez particulier.. J'ai déjà demandé sur TI Bank où je suis membre régulier, mais les utilisateurs de 68K n'y abondent pas. Alors je viens demander ici, le forum étant plus spécialisé dans la matière. happy

Voilà le topo :
J'ai voulu mettre à jour l'OS 1.00 de ma TI 89 HW1 par mon autre TI 89 en faisant "send product SW". ça s'est envoyer, tout doucement jusqu'à 98% et là, la calculatrice émmetrice m'affiche un message ERROR disant qqch dont je ne me rappelle plus bien..
Enfin, j'ai du retirer les piles de la calc réceptrice, et en les remettant, ça m'affiche "press I to install product code". Bon très bien, y a plus qu'à recommencer. Mais là, ça ne marche plus la mise à jour à partir d'une calto, et même à partir de l'ordi avec TILP I, ça ne donne rien, ça me dit que le timeout s'est écoulé..

En gros, la calc ne réagit pas.

Pourtant, lorsque je met la pile, elle m'affiche bien "press I...", et quand j'appuie sur I, elle m'affiche "Waiting...", comme il faut. Mais à ce moment là, que j'envoie un OS à partir d'une calc ou d'un pC, rien ne se passe ! (on peut parfois observer un léger clignotement du message "waiting...")

PS : Parfois, l'erreur de tilp est aussi "invalid checksum" ou qqch du genre..

Merci bien pour votre aide !
2
Ça pourrait être un mauvais contact dans le port link, ça arrive (vu que c'est une HW1, j'en déduis qu'elle ne doit pas être toute jeune). Est-ce que tu avais déjà constaté des erreurs de transmission avant ?

Si c'est le cas, il faudra ouvrer ta calculatrice et ressouder le connecteur.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
3
Alors la 1.00 n'est PAS compatible avec toutes les HW1, et oui, certaines sont brandé HW1 mais ne sont pas vraiment des HW1, mais plutot un mix entre des HW1 et HW2, et ces machines ne sont PAS compatible avec la 1.00, il leur faut la 1.05.

Par conte tu semble avoir un problemme sur le port IO
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
4
merci

Oui peut-être, mais je n'avais pas de problèmes particuliers avant, et j'ai justement vérifié si j'avais bien la tension de 3V environ sur les deux sorties et c'est le cas !
D'autant plus que lors de la première tentative, ça a fonctionné jusqu'à 98% ! --'

PS : J'ai le boot 1.05 build 15
5
La version du boot n'indiquera pas grand chose malheureusement, les versions n'ont jamais vraiment été référencé.

Ce qui est important et peux donner une indication par conte, c'est la date de fabrication (le numero de série gravé derriere la machine, genre "I-0898" (aout 1998)

avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
6
Sinon, l'OS que j'étais sur le point d'installer était le 2.04.

Le numéro en question, en entier : 12000703 I-0499B
7
RevB ? donc c'est une vrai HW1 et non une 1.5, de mémoire le 1.5 n'est apparu qu'avec la rev C.
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
8
Sinon, l'OS que j'étais sur le point d'installer était le 2.04.

Mauvaise idée: cet OS a un bug assez facile à rencontrer en utilisation normale, qui provoque un crash pouvant entraîner des pertes de données.
Utilise plutôt 2.05 ou 2.09, comme je te l'ai conseillé sur TI-Bank wink

Si l'OS que tu as essayé d'envoyer depuis une autre calculatrice était patché on-calc (par exemple avec MaxMem ou HW2/3Patch) sans changement de la signature, c'est normal que le transfert n'ait pas réussi.


Sur TI-Bank, je vois aussi que tu as essayé d'utiliser le vieux TILP I... Sur Win98, essaie un TILP II un peu plus ancien que 1.14, et essaie aussi W32Tran8x.
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
9
Lionel Debroux (./28) :
Oui, le bug de récupération des archives doit être corrigé dès AMS 2.04 (qui a un autre gros bug). Et attention, AMS 2.08/2.09 cassent certains hacks pour retrouver les adresses de variables internes.


J'ai vu ça en effet dans un autre sujet ! lol

Mais en fait c'est l'OS de ma TI 89 HW2 que j'ai voulu envoyer à ma HW1. (et c'est pendant ce transfert que ça a planté..) Sinon, pour le moment je ne déplore aucun problème de perte de mémoire sur la HW2. Même en cas de reset ! happy
Mais sinon, celui que je veux envoyer depuis l'ordi est en effet le 2.05. Et il se trouve en fait que ma 3è TI 89 (I-0798 encore plus vieille donc !) a l'os 2.05 justement. J'ai aussi essayé de l'envoyer à ma HW1 mais sans succès comme je vous le dis.
Bref, le problème est que peu importe l'os, je n'arrive plus à installer d'os sur ma TI ! Même revenir en 1.00 me ferait plaisir, parce que là, je ne peux même pas faire 1+1 avec ! :/
QUand une TI-68k est en mode d'installation par le Boot, on peut pas envoyer depuis une autre 89 (ce qui est idiot au passage) il faut absolument passer par une PC avec un soft qui va bien.
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
Lionel Debroux (./8) :
Si l'OS que tu as essayé d'envoyer depuis une autre calculatrice était patché on-calc (par exemple avec MaxMem ou HW2/3Patch) sans changement de la signature, c'est normal que le transfert n'ait pas réussi.


Sur TI-Bank, je vois aussi que tu as essayé d'utiliser le vieux TILP I... Sur Win98, essaie un TILP II un peu plus ancien que 1.14, et essaie aussi W32Tran8x.


Ouh il est fort possible que ça vienne de ça (même si je n'ai rien installé de ce genre moi, mais ptèt mon frère avant.) car l'erreur parlait d'une signature incorrecte ou qqch du genre !

Mais est-ce que cela peut empêcher de recommencer la mise à jour ?

Oui j'ai mis TILP I car je me suis dit que pour Win98 c'était suffisant, que les améliorations de l'autre ne concernerait que l'USB ou qqch du genre .. ^^
Crois-tu alors que d'essayer avec TILP II peut changer qqch ?
Tu as quoi comme cable ?
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
Godzil (./10) :
QUand une TI-68k est en mode d'installation par le Boot, on peut pas envoyer depuis une autre 89 (ce qui est idiot au passage) il faut absolument passer par une PC avec un soft qui va bien.

Ah oui ? Alors c'est normal que ça ne veuille plus marcher avec mes calto !
Donc il faut que j'essaye encore par l'ordi. Je verrai avec TILP II à l'occas.
Merci bien, et si vous avez encore des idées, n'hésitez pas ! wink
Mon câble : graylink (jack<>port série)
Il faut un vrai port série alors, meme si le graylink est moins sensible que le blacklink, il faut eviter les ports série USB
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
ok mais je ne pense pas que le problème vienne de là, car j'ai pu tester des transferts avec mes autres caltos sans avoir de problèmes ! (si, parfois des petits problèmes de contacts, mais qui ne durent pas longtemps..)
Vérifier le link de ta machine n'est pas idiot, une époque les problèmes de contacts étaient légion ici. Et d'autant plus sur une HW1.
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Si tu as de l'alcool, essaye de nettoyer les contacts de ton port IO

Si c'est comme sur les TI92 HW1, le port jack n'a pas de ressorts si bien qu'à force de mettre/enlever le câble, les contacts s'usent et les taux d'erreur augmentent...

Essaye de refaire la manip en tenant la prise jack un peu de bias pour s'assurer que le contact soit effectif, si c'est ça, il te suffira juste de changer la prise femelle de ton port IO
avatarWebmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // topics/6238-moved-jamais-jaurais-pense-faire-ca
D'accord merci pour tout ça, je vais faire des tests..
Bah TILP2 ne fonctionne pas sur windows 98 ! sad
Lionel Debroux (./8) :
Sur Win98, essaie un TILP II un peu plus ancien que 1.14, et essaie aussi W32Tran8x.

Ah, c'est ptèt ça ! wink
W32Tran8x <-- pas compatible TI68k, enfin il ne l'était pas a l'époque
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
Et pourquoi ne pas essayer TI-Connect ? Il fonctionne correctement sous Windows 98 (j'ai fait la mise à jour vers AMS 2.09 avec cette semaine)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Godzil (./22) :
W32Tran8x <-- pas compatible TI68k, enfin il ne l'était pas a l'époque

bah si, je l'utilisais pour ma 92+
avatarWebmaster du site Ti-FRv3 (et aussi de DevLynx)
Si moins de monde enculait le système, alors celui ci aurait plus de mal à nous sortir de si grosses merdes !
"L'erreur humaine est humaine"©Nil (2006) // topics/6238-moved-jamais-jaurais-pense-faire-ca
En effet, j'ai également utilisé W32Tran8x avec ma 89 et un "$5 cable" avant d'utiliser TILP wink
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
Ca a du etre dans les dernieres version, il n'était que Z80 a l'oriogine (je l'avais utilisé poru ma TI-82)
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.
Youuuuupiiiii ! =D =D =D

J'ai réussi !!
J'ai réussi à me dégoter un silver link et j'ai essayé avec TIOS downloader.
Bon, bah je suis content ! happy Merci pour tout !

Par contre, l'installation a duré 1 heure ! embarrassed

Maintenant que j'ai l'os 2.09 (TI OS Downloader ne m'a pas laissé le choix en fait..) j'aimerais bien appliquer le patch de Lionel pour l'os 2.09 ! happy
Mais comment faut-il procéder ?? Et est-ce qu'il faudra remettre à jour l'os avec un os modifié ? Ou est-ce un asm à exécuter ?

Merci
Loulou 54 (./27) :
Par contre, l'installation a duré 1 heure ! redface.gif
hum
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
hum
T'as un souci quelque part quand même :/
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Et est-ce qu'il faudra remettre à jour l'os avec un os modifié ?

Oui grin
Ou est-ce un asm à exécuter ?

Non, trop chiant à réaliser, moins fiable, plus long, etc.

(version plus détaillée: http://tibank.forumactif.com/t6749p15-c-est-la-panique#108128 )
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.