120

triso grin
avatar

121

Zerosquare (./115) :
Kevin Kofler (./110) :
En tant qu'actuel mainteneur upstream de Kompare, je ne peux te dire que vtff.gif !
En tant qu'actuel mainteneur upstream de Kompare, tu devrais plutôt demander à Godzil les raisons qui font qu'ils n'apprécie pas l'application que tu maintiens... enfin je dis ça, je dis rien hein...

Bah rien que les innombrables bugs dans la gestion des préférences qui m'a conduit purement et simplement a devoir supprimer tout le dossier de pref .kde .qt m'a vite saoulé ^^
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.

122

Y'a pas un portage de winmerge qui s'appellerait linuxmerge ou xmerge, et qui serait écrit SANS toolkit?

sinon y'a toujours gvim qui sait faire des diffs très honnêtes.

123

Yoshi Noir (./111) :
Une auto-balle dans le pied trilove

Bah non. Ce n'est pas moi qui fais le packaging Ubuntu, je n'y suis absolument pour rien! Développement upstream et packaging n'ont (généralement) strictement rien à voir, c'est justement cette distinction que beaucoup de néophytes de GNU/Linux ne comprennent pas!

Maintenant, si c'est le packaging Fedora qui est foireux, alors vous pouvez vous en prendre à moi. Mais le packaging Ubuntu n'est absolument pas sous mon contrôle, je n'ai aucune idée de ce qu'ils font avec mon logiciel.
squalyl (./113) :
quelqu'un a déja essayé kompare sous windows?

Oui, avec succès, cf. la ML kde-windows.
Godzil (./117) :
Non et pour une raison simple, une package binaire, ne peux pas contenir une application compilé avec différentes options, la ou une distribution source le fait sans soucis.

Certaines application sont utilisable avec ou sans X, emacs par exemple, mais c'est pas un tres bon exemple car les distribs font différent packages pour la version sans et la version avec X, enfin si ça reste un exemple vu qu'une distrib source n'a QU'UN seul package qu'on le veuille AVEC ou SANS X11.
Et ce n'est pas le seul exemple il suffit de regarder les USES de gentoo pour se rendre compte a quel point c'est reglable finement avec une distribution source, la ou une distrib binaire ne fait qu'imposer des choix arbitraires

Mais tout ça, ça n'a rien à voir avec ton problème de dépendances avec les paquetages Ubuntu de Kompare.
Nil (./118) :
(Il n'y a pas une variante de Kompare mais pour GTK ? #ange#)

L'équivalent GTK+ s'appelle Meld.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

124

C'est quasi impossible d'écrire sans toolkit, mais on n'est pas pour autant obligé d'utiliser un bulldozer. wxWidgets par exemple est particulièrement agréable pour l'utilisateur. Un peu moins pour le développeur peut être, mais il n'impose rien, utilise des contrôles natifs pour la plupart des systèmes (Windows, GNOME, ...), est la lib statique est plutôt petite (dans les 3 Meg).
avatarHighway Runners, mon jeu de racing à la Outrun qu'il est sorti le 14 décembre 2016 ! N'hésitez pas à me soutenir :)

https://itunes.apple.com/us/app/highway-runners/id964932741

125

./118, ./119, ./120: Kevin a mentionné meld wink

./124: ça n'est pas impossible d'écrire sans toolkit, c'est juste très chiant - et le look & feel ne s'intégrera pas parfaitement au desktop grin

Sinon: dans http://packages.ubuntu.com/karmic/kompare et http://packages.ubuntu.com/lucid/kompare , la dépendance à KOffice n'est pas de premier niveau, et je ne la vois pas au second niveau non plus. Peut-être as-tu installé en même temps des packages recommandés qui dépendent transitivement de KOffice ?
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.

126

Golden -> rotfl
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !

127

Lionel Debroux (./125) :
Sinon: dans http://packages.ubuntu.com/karmic/kompare et http://packages.ubuntu.com/lucid/kompare , la dépendance à KOffice n'est pas de premier niveau, et je ne la vois pas au second niveau non plus. Peut-être as-tu installé en même temps des packages recommandés qui dépendent transitivement de KOffice ?

Franchement je ne sais pas, je n'ai pas installé ubuntu sur la machine a la base, peut=etre que d'autres paquets on tiré koffice quand j'ai demandé kompare, je sais juste que la j'ai koffice que je n'ai pas demandé. Enfin rien de bien grave, ubuntu disparaitra des que j'aurais le temps de changer de disctrib.


Sinon sans un toolkit, oui c'est possible (XLib powa ^^) J'avais meme commencé un toolkit en 2003 ^^
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.

128

Brunni (./124) :
C'est quasi impossible d'écrire sans toolkit, mais on n'est pas pour autant obligé d'utiliser un bulldozer. wxWidgets par exemple est particulièrement agréable pour l'utilisateur. Un peu moins pour le développeur peut être, mais il n'impose rien, utilise des contrôles natifs pour la plupart des systèmes (Windows, GNOME, ...), est la lib statique est plutôt petite (dans les 3 Meg).

Bah, sous GNU/Linux, wxWidgets, c'est juste GTK+ avec des bogues en plus. roll
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

129

Je ne sais pas pourquoi mais je ne te sens pas super impartial sur ce coup happy
avatarHighway Runners, mon jeu de racing à la Outrun qu'il est sorti le 14 décembre 2016 ! N'hésitez pas à me soutenir :)

https://itunes.apple.com/us/app/highway-runners/id964932741

130

Bah, wxWidgets sous GNU/Linux utilise toujours GTK+, donc c'est juste un wrapper inutile en plus.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

131

j'utilise gnome, j'ai déjà installé les lib kde car j'utilise Kate pour dev

->

DqeG

et KOffice n'est pas installé

IbZA

132

Tiens c'est vrai, moi aussi j'ai Kompare sans KOffice.
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !

133

C'est parce que tu utilises l'interface graphique et non apt-get embarrassed
avatarHighway Runners, mon jeu de racing à la Outrun qu'il est sorti le 14 décembre 2016 ! N'hésitez pas à me soutenir :)

https://itunes.apple.com/us/app/highway-runners/id964932741

134

attention je n'ai pas dit que installer kompare isntalle forcement koffice, juste que dans mon cas, c'est ce qui c'est passé.
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.

135

Oué ben ya bien une raison à ça, ou tu t'es planté, ou tu as demandé autre chose que Kompare, mais le problème n'est absolument pas Kompare.
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !

136

Ben il se peut aussi qu'il soit mal packagé, non ?
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo

137

Folco (./135) :
Oué ben ya bien une raison à ça, ou tu t'es planté, ou tu as demandé autre chose que Kompare, mais le problème n'est absolument pas Kompare.

oui

apt-get install kompare

je peux facilement me planter c'est sur
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.

138

Brunni (./133) :
C'est parce que tu utilises l'interface graphique et non apt-get redface.gif
???
mk@mk-laptop:~$ sudo apt-get install kompare
[sudo] password for mk:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Paquets suggérés :
khelpcenter4
Les NOUVEAUX paquets suivants seront installés :
kompare
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 331ko dans les archives.
Après cette opération, 1 188ko d'espace disque supplémentaires seront utilisés.
Réception de : 1 http://fr.archive.ubuntu.com/ubuntu/ lucid/main kompare 4:4.4.2-0ubuntu3 [331kB]
331ko réceptionnés en 3s (109ko/s)
Sélection du paquet kompare précédemment désélectionné.
(Lecture de la base de données... 218455 fichiers et répertoires déjà installés.)
Dépaquetage de kompare (à partir de .../kompare_4%3a4.4.2-0ubuntu3_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « python-gmenu »...
Rebuilding /usr/share/applications/desktop.fr_FR.utf8.cache...
Traitement des actions différées (« triggers ») pour « hicolor-icon-theme »...
Traitement des actions différées (« triggers ») pour « python-support »...
Paramétrage de kompare (4:4.4.2-0ubuntu3) ...

Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking placemk@mk-laptop:~$

139

Godzil (./137) :
Folco (./135) :
Oué ben ya bien une raison à ça, ou tu t'es planté, ou tu as demandé autre chose que Kompare, mais le problème n'est absolument pas Kompare.

oui

apt-get install kompare

je peux facilement me planter c'est sur

Tu avais autre chose en attente dans le cache peut-être ? Je n'en sais rien, mais c'est tout de même très étonnant !
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !

140

libqt4-qt3support n'a pas encore été totalement viré?

141

squalyl (./140) :
libqt4-qt3support n'a pas encore été totalement viré?

Non, et ça n'est pas près de l'être, et Kompare ne marche pas sans en tout cas.

Pour le problème de Godzil, à mon avis, il a activé l'option qui installe automatiquement les recommends et suggests.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

142

génial. KDE5 contiendra encore du qt3 a ce rythme.

143

KDE5 n'existera jamais. 2012 c'est dans 2 ans tongue
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes

144

GoldenCrystal (./143) :
KDE5 n'existera jamais. 2012 c'est dans 2 ans tongue


Non en fait KDE5 n'existera jamais pour un autre raison, il va etre remplacé par KvDE 0.96beta 8
avatarProud to be CAKE©®™


GCC4TI importe qui a problème en Autriche, pour l'UE plus et une encore de correspours nucléaire, ce n'est pas ytre d'instérier. L'état très même contraire, toujours reconstruire un pouvoir une choyer d'aucrée de compris le plus mite de genre, ce n'est pas moins)
Stalin est l'élection de la langie.

145

trisotfl
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes

146

Il n'y a à cette heure aucun plan pour un Qt 5 et/ou KDE 5.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

147

Godzil -> gni
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !

148

(notez que Kevin n'a pas démenti pour KvDE hehe)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo

149

Je démentis aussi l'existence de KvDE.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité

150