squalyl: interaction entre le repository de base Lenny et le repository backports, voir http://packages.debian.org/search?keywords=libmysqlclient-dev .
Manifestement, ce que tu veux, ici, c'est `apt-get install libmysqlclient15-dev` wink
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
squalyl@dedisol:~/boinc_trunk$ sudo apt-get install libmysqlclient15-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
libmysqlclient15-dev est déjà la plus récente version disponible.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 4 non mis à jour.
gol mais il s'y est mis quand? tout a l'heure il m'a jeté en disant qu'il le trouvait pas. Il a du se mettre furtivement en tentant la v16.

edit: ah non c'est lionel qui me fait des blagues grin
Yoshi Noir (./39) :
J'essaie d'installer Midori 0.2.6 sur mon Eee PC.Tous ces paquets de dev sont utiles pour compiler le code source étant donné qu'il n'y a pas de binaire précompilé de cette version.

Bah, c'est bien ça ton problème, tu essaies de compiler quelque chose à partir des sources, faut pas te plaindre qu'il te faut des paquetages -dev alors!

Ce que fait un utilisateur normal, c'est de prendre la version disponible dans le dépôt de sa distribution, pas forcément la plus récente. (Soit dit en passant que sous une certaine autre distribution… voici et voilà! tongue)

Mais si tu veux absolument la version la plus récente, il y a des PPAs pour les versions à jour de Ubuntu (Karmic et Lucid). C'est ça la bonne solution, pas la compilation à partir des sources!
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
Kevin Kofler (./62) :
. (Soit dit en passant que sous une certaine autre distribution… voici et voilà! tongue.gif )

Moi aussi, je peux jouer ?
[xxxxx ~ ]$ yaourt -S midori
Mot de passe : 
Résolution des dépendances...
Recherche des conflits possibles entre paquets...

Cibles (4): aspell-0.60.6-4  enchant-1.6.0-1  libwebkit-1.2.1-1  midori-0.2.6-1

Taille totale des paquets (téléchargement):   6,82 Mo
Taille totale des paquets (installation):   35,19 Mo

Procéder à l'installation ? [O/n] 
avatar
Bah, dans tous les cas, le message est le même: arrêtez de compiler les logiciels non modifiés vous-mêmes, c'est pour ça que les packageurs existent! Dans le cas de Ubuntu (la distribution que Yoshi Noir utilise), une recherche "Midori 0.2.6" Ubuntu dans un moteur de recherche suffit pour trouver les 2 PPAs qu'il faut (le PPA Midori et le PPA WebKit). Il faut perdre ce réflexe de compiler à partir des sources et prendre le réflexe de chercher un dépôt tiers si le dépôt officiel n'a pas ce qu'on veut. Les dépôts tiers sont là pour ça.

(Et même quand on veut modifier un logiciel, la bonne méthode est en général de prendre le paquetage source (par exemple le SRPM), rajouter un ou plusieurs patch(es) et compiler le paquetage résultant. Mais l'utilisateur moyen ne va pas et ne devrait pas s'amuser à modifier les logiciels.)
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
On est donc bien d'accord. Quand tu veux faire un truc sous Linux, ça marche jamais.
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
GoldenCrystal (./65) :
On est donc bien d'accord. Quand tu veux faire un truc sous Linux, ça marche jamais.

Hein? Ce n'est pas du tout ce que j'ai dit!

Il faut que tu abandonnes une fois pour toutes cette idée stupide qu'installer un logiciel sous GNU/Linux, ça se fait à partir des sources! Un utilisateur moyen installe des paquetages binaires, ils sont là pour ça! Et ça, ça marche toujours et ça ne nécessite pas des centaines de MO en paquetages -dev(el).
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
T'es vraiment bouché kéouin féé Dora, je voulais installer un truc tout a fait normal, la lib cliente de développement de mysql. c'est censé être filé par debian. Et ce qui est rigolo, c'est que le système de rapport de bugs de debian n'est pas configuré par défaut pour que cet envoi fonctionne. Sans parler du format de monomaniaque qu'il faut respecter pour faire le rapport a la main.

sinon, apt-get install boinc-server ne marche pas, et yum install boinc-server non plus, tu le savais? triso
GoldenCrystal (./65) :
On est donc bien d'accord. Quand tu veux faire un truc sous Linux, ça marche jamais.


Bah installer un logiciel sous Windows, ça marche en général très bien. C'est le supprimer proprement qui pose problème sad
avatar
GoldenCrystal (./55) :
Le problème de apt-get autoremove (et équivalent sur tous les gestionnaires de paquets), c'est que si tu as eu le malheur de demander explicitement un des paquets dont tu n'as plus besoin, tout le système est niqué.

gni ?? Bien sûr que non... En tout cas j'ai jamais réussi à niquer quoi que ce soit, autoremove ne va chercher que les paquets installés comme dépendance dont les programmes qui les ont nécessités ne sont plus là
Il doit bien exister une commande permettant de trouver les paquets orphelins, mais c'est toujours le bordel à gérer.

apt-get autoremove...
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
oui, c'est un des trucs qui marche autoremove.
Tudieu, quel bordel... j'ai l'impression de voir la politique française. A Droite, Windows et son gros groupe méchant mais majoritaire et kivabien, à Gauche Linux avec de belles idées et un avenir radieux le jour où ils se sentiront capables d'avancer sans se tirer dans les pattes entre distributions (vous en voyez beaucoup vous, des débats Windows ? "XP c'est mieux que Seven, je reste dessus" - "nan, c'est pas vrai, Seven c'est plus joli et plus sécurisé" - "c'est parce que tu ne sais pas protéger ton ordi, noob" (etc etc)).

Ca manque aussi à ta crédibilité Kevin, cette impression que non seulement tu attaques Microsoft (et Apple bien sûr), mais tu attaques aussi ceux qui sont supposés être de ton côté.
avatar« Nous avons propagé sur Extranet une histoire fabriquée de toutes pièces selon laquelle une certaine disposition d'étoiles, vue depuis la planète d'origine des butariens, formaient le visage d'une déesse galarienne.
Sans chercher à vérifier ces informations, certains ont décrété que c'était la preuve de l'existence de la déesse. Ceux qui notaient le manque de preuves se faisaient attaquer. »

Legion, geth trolleur à portée galactique
squalyl (./67) :
je voulais installer un truc tout a fait normal, la lib cliente de développement de mysql. c'est censé être filé par debian. Et ce qui est rigolo, c'est que le système de rapport de bugs de debian n'est pas configuré par défaut pour que cet envoi fonctionne. Sans parler du format de monomaniaque qu'il faut respecter pour faire le rapport a la main.

Bah, c'est Debian, quoi. gni
Meowcate (./71) :
vous en voyez beaucoup vous, des débats Windows ? "XP c'est mieux que Seven, je reste dessus" - "nan, c'est pas vrai, Seven c'est plus joli et plus sécurisé" - "c'est parce que tu ne sais pas protéger ton ordi, noob" (etc etc)

C'est parce que là-bas, tu n'as pas de choix. Un débat entre XP et Seven, c'est comme un débat entre Fedora 11 et 13, c'est stupide. Ce ne sont que des versions plus ou moins récentes de la même chose, il n'y a aucun choix. GNU/Linux te fournit de vraies alternatives entre lesquelles choisir, donc forcément il y a des débats entre les alternatives. C'est ça la liberté de choix.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
Folco (./69) :
GoldenCrystal (./55) :
Le problème de apt-get autoremove (et équivalent sur tous les gestionnaires de paquets), c'est que si tu as eu le malheur de demander explicitement un des paquets dont tu n'as plus besoin, tout le système est niqué.

gni ?? Bien sûr que non... En tout cas j'ai jamais réussi à niquer quoi que ce soit, autoremove ne va chercher que les paquets installés comme dépendance dont les programmes qui les ont nécessités ne sont plus là
Il doit bien exister une commande permettant de trouver les paquets orphelins, mais c'est toujours le bordel à gérer.

apt-get autoremove...

Relis mon post, tout est expliqué dedans. Je te le met même en gras.
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Kevin Kofler (./73) :
Bah, c'est Debian, quoi. gni.gif


j'espère que le gni souligne que c'est l'hopital qui se fout de la charité...
(Je ne comprends pas pourquoi tu voudrais utiliser autoremove avec un seul paquet triso)
avatar
Golden -> Ah ben j'ai jamais fait comme ça et j'ai jamais rien niqué, je sais pas comment tu t'y prends tongue
Je fais d'abord un remove de ce que je veux, puis un auto-remove pour tout nettoyer, c'est fini.
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Kevin Kofler (./64) :
Bah, dans tous les cas, le message est le même: arrêtez de compiler les logiciels non modifiés vous-mêmes, c'est pour ça que les packageurs existent!



Moi ce que j'y comprends c'est que sous Linux c'est comme sous Windows en fait.
avatar"- Nigga you know what the fuck I want, nigga: I want your motherfuckin' Daytons, and your motherfuckin' stereo! And I'll take a double burger with cheese!
- WHUT?"
I LOVE TO HATE/I HATE YOUR LOVE -AND I CAN'T FEEL AFFECTION FOR PEOPLE LIKE YOU!
CAALGOOONNNNN [TELLMESOMETHINGIDONTKNOWSHOWMESOMETHINGICANTUSEPUSHTHEBUTTONSCONNECTTHEGODDAMNDOTS] (Si Dieu existe il doit me détester...)
(cross) faut juste que pas trop de trucs ne dépendent de ce que tu veux supprimer, parce que sinon tu fous ta bécane à poil triso
squalyl (./74) :
Kevin Kofler (./73) :
Bah, c'est Debian, quoi. gni.gif

j'espère que le gni souligne que c'est l'hopital qui se fout de la charité...

Non, il souligne que c'est de la provocation. tongue Mais il ne s'agit pas d'un pur troll, mais d'une provocation basée sur les faits, je suis désolé…
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
T'es pardonné grin

oh si c'est un troll debian/fedora qui est en train de taper à la porte, mais je lui ouvrirai pas tongue
Nil (./75) :
(Je ne comprends pas pourquoi tu voudrais utiliser autoremove avec un seul paquet triso)

Hmm oui j'aurai du écrire "sélectionner" pour être plus clair, il est vrai ^^
Donc je réexplique.
lib-pourri-merdique-1.5.4.2-rc1_alpha a été poussé par appli-pourri-inutile_2.9.7_beta5, mais tu as pour une raison X par la suite, sélectionné le paquet lib-pourri-merdique-1.5.4.2-rc1_alpha. Le paquet étant déjà installé, rien ne se passe.
Puis tu désinstalles appli-pourri-inutile_2.9.7_beta5 parce que c'est naze et que ça marche pas (comme 70% des applications que tu peux tester).
Mais malheureusement, lib-pourri-merdique-1.5.4.2-rc1_alpha va rester installée ainsi que toutes ses dépendances. Pourtant elle n'est réellement plus utilisée. Et tu l'as oubliée dans un coin pendant qu'elle alourdit ton système.
(Parce qu'elle a beau servir à rien, elle va quand même prendre du temps à se mettre à jour ainsi que ses dépendances)
Bref. ça devrait être plus clair tongue
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Bah, c'est ta raison X que tu devrais expliciter, parce qu'il n'y a pas de bonne raison de sélectionner explicitement cette lib, surtout si tu ne t'en sers que pour l'application pour laquelle elle a été installée automatiquement.
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
Kevin Kofler (./62) :
Bah, c'est bien ça ton problème, tu essaies de compiler quelque chose à partir des sources, faut pas te plaindre qu'il te faut des paquetages -dev alors!


Désolé de faire confiance à la source première du soft : le site web de son développeur...
Et en général, les développeurs nux, c'est « J'ai fait le prog, démerdez-vous pour l'adapter aux autres distros ». J'ai connu ça avec VLC, dont le préposé aux relations publiques sur PC INpact est un véritable trou du cul.

Le problèm des sources tierces c'est qu'il n'y a aucune publicité autour d'elle. Je te remercie donc de m'avoir indiqué les PPA que je n'aurais certainement pas trouvé tout seul (ou alors par hasard en lisant des forums au hasard)
si tu avais installé ubuntu tweak il t'aurais filé les ppa
6ugM
GoldenCrystal (./81) :
mais tu as pour une raison X par la suite

Euh à part la raison "je suis juste très con" je vois pas trop en fait triso
Non franchement, trouver linux nul, c'est une chose, partir du principe que tout utilisateur va l'utiliser comme un abruti fini, c'est pas très fin quoi tongue

Qui plus est les majs, pour ce que ça prend du temps, franchement... ça met quoi, 1/2 seconde une lib qui se met à jour ? Et à l'heure de nos connexions, c'est que dalle de temps de dl. Et les majs sont globalement rares pour un paquet précis...
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Ben par exemple ça m'arrive de forcer un paquet parce qu'il marche pas et je veux voir pourquoi.
Ou parce que je veux tester un truc.
Des fois c juste une erreur.
Mais après ça fout quand même la merde.
J'ai pas dit que linux est nul à cause de ça.
De toutes façons le principe de la gestions de paquets sux complètement avec ou sans sans cette fonction...
Oui 1/2 seconde * 250 libs ça fait 120 secondes. Et tu supposes que j'ai une connexion 20M. Bah je suis bien heureux pour toi, mais moi c'est pas mon cas, et les 200Mo de mises à jour toutes les deux à trois semaines c'est tout simplement du foutage de gueule.
Soit t'as plein de logiciels qui marchent pas, soit tu te tapes de Go de téléchargement "pour le fun" régulièrement. On repassera.
J'ai beau regarder, Windows n'avance pas vraiment plus lentement (au contraire), pourtant le volume de mises à jour n'est pas si élevé.
Au moins, y'a des gens comme chez Google qui ont trouvé comment réduire la taille de leurs mises à jour.
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Yoshi Noir (./83) :
Désolé de faire confiance à la source première du soft : le site web de son développeur...

Ce n'est en général pas le bon endroit pour chercher des paquetages prêts à l'emploi. Les développeurs ne sont même pas au courant de quels paquetages existent pour quelle distribution, donc ils te proposeront juste le code source et peut-être des paquetages qu'ils ont fait eux-mêmes pour certaines distributions (de qualité variable).

Le bon endroit pour chercher un logiciel est 1. le dépôt officiel de la distribution, 2. les dépôts tiers courants, 3. les dépôts tiers moins courants, à trouver avec un moteur de recherche et seulement 4. le site du logiciel. Et il faut toujours préférer les paquetages binaires, leur packageur aura déjà fait tout le boulot de compilation pour toi.
Et en général, les développeurs nux, c'est « J'ai fait le prog, démerdez-vous pour l'adapter aux autres distros ».

Bah oui, c'est normal, c'est bien pour ça qu'il ne faut pas aller directement sur le site des développeurs pour installer un logiciel. C'est le boulot du packageur de faire ce travail d'adaptation à la distribution.
Le problèm des sources tierces c'est qu'il n'y a aucune publicité autour d'elle. Je te remercie donc de m'avoir indiqué les PPA que je n'aurais certainement pas trouvé tout seul (ou alors par hasard en lisant des forums au hasard)

Apprends à utiliser un moteur de recherche. Le lien que j'ai donné a été le premier résultat!
avatarMes news pour calculatrices TI: Ti-Gen
Mes projets PC pour calculatrices TI: TIGCC, CalcForge (CalcForgeLP, Emu-TIGCC)
Mes chans IRC: #tigcc et #inspired sur irc.freequest.net (UTF-8)

Liberté, Égalité, Fraternité
Kevin Kofler (./88) :
Les développeurs ne sont même pas au courant de quels paquetages existent pour quelle distribution
Ah bravo!
Kevin Kofler (./88) :
2. les dépôts tiers courants, 3. les dépôts tiers moins courants,
Quelle fiabilité!
GoldenCrystal (./86) :
Soit t'as plein de logiciels qui marchent pas, soit tu te tapes de Go de téléchargement "pour le fun" régulièrement. On repassera.

Mais n'importe quoi, t'exagères complètement. sick

Si tu prends unedistro de bêtas, genre Fedora, ok ya pas mal de majs (et c'est 200 Mo/mois sur mon desktop, pas des Go par semaine).
Et sur mes Debian stables, je me tape genre 5 Mo tous les 15 jours, rien qui casse des briques. Tes chiffres sont fantaisistes. Ou tu connais mal, ou tu trolles à outrance (je penche pour la solution #2 tongue).
GoldenCrystal (./86) :
Au moins, y'a des gens comme chez Google qui ont trouvé comment réduire la taille de leurs mises à jour.

Ca arrive aussi dans les distros.
GoldenCrystal (./86) :
Oui 1/2 seconde * 250 libs ça fait 120 secondes

Han putain, 2 minutes dans la journée c'est monumental eeek
Surtout que quand tu vois pisser tu fais ça et c'est marre. Mais passons, ça t'a l'air insurmontable tongue
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Folco (./85) :
Non franchement, trouver linux nul, c'est une chose, partir du principe que tout utilisateur va l'utiliser comme un abruti fini, c'est pas très fin quoi tongue

Kevin utilise Linux. # (c'est pas plus fin je sais)
A part ça je suis globalement d'accord que les paquets ça marche bien, mais ça n'a tendance à être le cas que pour les logiciels courants sur des distros courantes. C'est d'ailleurs +/- la seule raison qui fait que je reste sous Ubuntu.
Maintenant suivant où en entreprise (lorsqu'ils utilisent des LL), Linux est un avantage pour l'installation de logiciels. Sous Mac on a souvent des soucis parce que les deux systèmes ne sont pas aussi proches qu'on pourrait le penser / que certains ne l'espèrent. Sous Windows soit on utilise cygwin-tout-pourri, soit on a de la chance d'avoir un portage de qualité (heureusement ce n'est pas rare vu la grande utilisation du système), soit on doit toujours faire différent des autres (e.g. tortoise là où les autres le font à la command line), et en cas de problème on se sent bien con et seul... hehe
avatarHighway Runners, mon jeu de racing à la Outrun qu'il est sorti le 14 décembre 2016 ! N'hésitez pas à me soutenir :)

https://itunes.apple.com/us/app/highway-runners/id964932741