Posté le 07/07/2010 à 09:47 Membre depuis le 29/10/2003, 25435 messages
Kevin Kofler (./23) :
Parce que tu as besoin de son pour faire des calculs?

C'est long à expliquer, mais dans le cadre de mes cours à la fac, je devais utiliser les fonctionnalités sonores de Matlab, oui.


Sinon, bons résumés de Meowcate smile
Posté le 07/07/2010 à 10:34 Membre depuis le 15/06/2003, 8330 messages
Kevin doit sans doute ignorer que Matlab sert entre autres (et souvent) à faire du traitement du signal, incluant son et image...
Moi sinon j'aurai fait plus court: "Linux c'est pourri et ça sert à rien." ou bien "Si tu ne sais pas ce que c'est alors tu n'en a pas besoin."
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 07/07/2010 à 10:41 Membre depuis le 28/10/2001, 7625 messages
Gros troll tongue
Le post de Meowcate ( ./24 ) est beaucoup plus équilibré wink
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
Posté le 07/07/2010 à 10:52 Membre depuis le 18/06/2001, -26075 message
Autre chose aussi : Linux n'est pas nécessairement plus compliqué, mais différent de Windows : c'est le manque d'habitude et non sa complexité intrinsèque qui le rend un peu dur à aborder quand on ne connait que Windows. Je m'ennorgueuillis que ma femme préfère Linux à Windows chapo, parce qu'elle le trouve beaucoup plus simple à utiliser (il faut dire que je lui ai configuré son KDE pour que tout soit très simple).

Donc au final et amha, c'est une grosse question d'habitude, et on a tendance à trouver plus facile le système qu'on est le plus habitué à utiliser, tout simplement.
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 07/07/2010 à 12:07 Membre depuis le 13/06/2001, 73063 messages
Moi aussi, je veux jouer !
Folco (./10) :
Yoshi Noir (./3) :
les gens prônant Linux étant surtout motivés soit pour des raisons politiques, soit parce que tout ce qui peut supplanter Windows est bon à prendre.

Dans mon cas, c'est juste parce que je trouve plus facile de développer sous Linux que sous Windows (mais je ne suis qu'amateur, pas pro).
J'utilise Linux et Windows. Chacun pour moi a ses points forts, donc j'utilise chacun dans le sens qui me convient le mieux.

Bah exactement que toi sauf que je suis pro (enfin, ça ne veut pas dire grand chose, pro ou amateur, cela dit).

Et comme moi aussi je veux jouer à cékikialaplugrosse, je suis sous Arch Linux+XFCE. Na.
avatar
Posté le 07/07/2010 à 17:01 Membre depuis le 14/08/2003, 7340 messages
Linux, c'est surtout intéressant pour avoir un gros paquet.
Posté le 07/07/2010 à 17:37 Membre depuis le 27/10/2007, 171 messages
OK merci à tous pour vos réponses !
Posté le 12/07/2010 à 12:22 Membre depuis le 29/10/2003, 25435 messages
Recyclage de topic. À propos de l'installation des programmes sous nux. Finalement je comprends GoldenCrystal et j'avais totalement oublié la chose :

Les NOUVEAUX paquets suivants seront installés :
  autoconf automake autotools-dev build-essential cvs debhelper dpkg-dev fakeroot g++ g++-4.4 gettext html2text intltool
  intltool-debian irb1.8 libatk1.0-dev libcairo2-dev libdirectfb-dev libdirectfb-extra libexpat1-dev libfontconfig1-dev
  libfreetype6-dev libgcrypt11-dev libgettext-ruby-util libgettext-ruby1.8 libgnutls-dev libgpg-error-dev libgtk2.0-dev
  libice-dev libidn11-dev libjpeg62-dev liblocale-ruby1.8 libmail-sendmail-perl libpango1.0-dev libpixman-1-dev
  libpng12-dev libpthread-stubs0 libpthread-stubs0-dev libreadline-ruby1.8 libruby libruby1.8 libsm-dev libsoup2.4-dev
  libsqlite3-dev libstdc++6-4.4-dev libsys-hostname-long-perl libsysfs-dev libtasn1-3-dev libunique-dev libwebkit-dev
  libx11-dev libxau-dev libxcb-render-util0-dev libxcb-render0-dev libxcb1-dev libxcomposite-dev libxcursor-dev
  libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev libxft-dev libxi-dev libxinerama-dev libxml2-dev libxrandr-dev
  libxrender-dev m4 patch po-debconf ruby1.8 x11proto-composite-dev x11proto-core-dev x11proto-damage-dev
  x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
  x11proto-xinerama-dev xtrans-dev xz-utils
0 mis à jour, 83 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 31,3Mo dans les archives.
Après cette opération, 106Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ?  


Tout ça pour installer un navigateur internet de 4 Mo. Cool.
Posté le 12/07/2010 à 12:58 Membre depuis le 18/06/2001, -26075 message
Au moins, c'est automatique.

Sinon c'est quoi ton nav ? hum Qu'est-ce que tous ces paquets de dev viennent foutre ?
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 12/07/2010 à 13:08 Membre depuis le 29/10/2003, 25435 messages
J'essaie d'installer Midori 0.2.6 sur mon Eee PC.
Tous ces paquets de dev sont utiles pour compiler le code source étant donné qu'il n'y a pas de binaire précompilé de cette version.

Problème, à l'installation j'ai ça :

yoshinoir@ubuntu:~/midori$ sudo ./waf install
Waf: Entering directory `/home/yoshinoir/midori/_build_'
Can't open source directory midori: Aucun fichier ou dossier de ce type at /usr/bin/gtkdoc-scan line 214.
Can't open ./midori-decl.txt at /usr/bin/gtkdoc-mktmpl line 848.
Can't open ./midori-sections.txt: Aucun fichier ou dossier de ce type at /usr/bin/gtkdoc-mkdb line 1132.
head: Ne peut ouvrir `../midori.sgml' en lecture: Aucun fichier ou dossier de ce type
/usr/bin/jade:E: cannot find "../midori.sgml"; tried "../midori.sgml", "/usr/local/share/sgml/../midori.sgml", "/usr/share/sgml/../midori.sgml"
/usr/bin/jade:/usr/share/gtk-doc/data/gtk-doc.dcl:106:2:E: end of document in prolog
Created documentation for midori. 
Can't open source directory katze: Aucun fichier ou dossier de ce type at /usr/bin/gtkdoc-scan line 214.
Can't open ./katze-decl.txt at /usr/bin/gtkdoc-mktmpl line 848.
Can't open ./katze-sections.txt: Aucun fichier ou dossier de ce type at /usr/bin/gtkdoc-mkdb line 1132.
head: Ne peut ouvrir `../katze.sgml' en lecture: Aucun fichier ou dossier de ce type
/usr/bin/jade:E: cannot find "../katze.sgml"; tried "../katze.sgml", "/usr/local/share/sgml/../katze.sgml", "/usr/share/sgml/../katze.sgml"
/usr/bin/jade:/usr/share/gtk-doc/data/gtk-doc.dcl:106:2:E: end of document in prolog
Created documentation for katze. 
Waf: Leaving directory `/home/yoshinoir/midori/_build_'
'install' finished successfully (6.678s)
gtk-update-icon-cache: Failed to open file /usr/local/share/icons/hicolor/.icon-theme.cache : Aucun fichier ou dossier de ce type
Icon cache not updated. After install, run this: 
gtk-update-icon-cache -q -f -t /usr/local/share/icons/hicolor 


Chose qui n'est jamais arrivée sur mon autre PC. Ce qui fait que j'ai 200 Mo qui occupent de l'espace pour rien. Youpi.
Posté le 12/07/2010 à 13:08 Membre depuis le 28/10/2001, 7625 messages
En effet, c'est très bizarre que tant de packages dev - ou packaging (debhelper ?!) soient tirés transitivement.
Tu installes un paquet source, ou quoi ? grin
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.
Posté le 12/07/2010 à 13:26 Membre depuis le 29/10/2003, 25435 messages
Je ne fais que suivre les directives pour installer ce nav sous Ubuntu. Sauf qu'il y a un effet « Kinder Surprise », tu veux une librairie, y'en a 18 qui suivent derrière.
Et _toutes_ ces libs sont importantes, sinon la configuration foirera lamentablement.
Posté le 12/07/2010 à 13:26 Membre depuis le 16/06/2001, 69803 messages
C'est énorme trilove
Posté le 12/07/2010 à 13:29 Membre depuis le 15/06/2003, 8330 messages
Merci d'illustrer exactement ce que je disais love
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 12/07/2010 à 13:46 Membre depuis le 18/06/2001, -26075 message
Le problème c'est que là c'est carrément le soft dont il a besoin qui est mal packagé, ça ne remet pas en cause la validité du système en soi. Sous Win on te filerais les sources d'un soft ça serait exactement le même merdier.

YN -> Si tu fais une croix sur ce nav et veut récupérer ton espace, vire juste le nav, tout le reste devrait dégager avec (en tout cas c'est le cas sous Debian, donc j'imagine aussi sur Ubuntu).
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 12/07/2010 à 13:50 Membre depuis le 27/04/2006, 60494 messages
Folco (./44) :
Sous Win on te filerais les sources d'un soft ça serait exactement le même merdier.
Ouais enfin, s'il y a autant de paquets sources sous Linux, c'est pas pour la beauté de l'open-source, hein tongue ; c'est parce qu'il n'y a pas de paquetages binaires universels (ni de paquetages universels tout court d'ailleurs)
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 12/07/2010 à 14:00 Membre depuis le 21/05/2004, 6467 messages
Folco (./44) :
Le problème c'est que là c'est carrément le soft dont il a besoin qui est mal packagé, ça ne remet pas en cause la validité du système en soi. Sous Win on te filerais les sources d'un soft ça serait exactement le même merdier.

Non, en général les développeurs sous Windows évitent d'avoir à faire appel à 40 librairies différentes. Les principales sont déjà inclusent avec le noyaux, les annexes (genre zlib ou libpng) livrées éventuellement avec le programme. Bon après, quand on tape dans des softs comme PhotoShop, je dis pas, mais l'installation s'occupe de ces soucis...

Kochise
avatarSi Dieu m'a de nouveau fait homme, cette fois il m'a pas raté : marcher sur l'eau et dupliquer les pains, ça marche p'us :/
Posté le 12/07/2010 à 14:01 Membre depuis le 15/06/2003, 8330 messages
./44 > Sous win tu n'as jamais (sauf cas très particulier) à compiler, car la plupart des gens n'ont pas de quoi compiler (C'est quand même anormal de fournir un compilateur en standard avec un OS, tu ne trouves pas ?) et parce qu'un binaire Windows a le mérite de fonctionner out-of-the-box pour peu que tu aies les bonnes dll à portée et un OS supporté. (Exception faite des gros trucs comme Office ou Visual Studio qui ont une grosse procédure d'installation avec des clés de registre spécifiques à configurer)
D'autre part, on n'utilise pas GCC, ni make, ni les autotools de merde. Et un build MSVC déjà bien configuré, c'est quand même assez difficile à faire foirer. (Contrairement à un build autotools qui est déjà super complexe à faire marcher initialement, et une merde à utiliser et maintenir)
J'en ai compilé pas mal de trucs. Tu ouvres le fichier projet, tu met à niveau si besoin (c'est parfois de vieilles versions de VS), ce qui peut demander de bidouiller quelques paramètres. Tu cliques sur le bouton compiler, et c'est fini.
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 12/07/2010 à 14:03 Membre depuis le 27/04/2006, 60494 messages
Kochise (./46) :
Non, en général les développeurs sous Windows évitent d'avoir à faire appel à 40 librairies différentes.
C'est pas toujours vrai (DirectX, GDI+, .NET)... les différences principales avec Linux c'est que les libs assurent généralement la compatibilité ascendante, et qu'on peut les distribuer sans problème sous forme binaire.
avatarZeroblog

« Tout homme porte sur l'épaule gauche un singe et, sur l'épaule droite, un perroquet. » — Jean Cocteau
« Moi je cherche plus de logique non plus. C'est surement pour cela que j'apprécie les Ataris, ils sont aussi logiques que moi ! » — GT Turbo
Posté le 12/07/2010 à 14:04Edité par Folco le 12/07/2010 à 14:05 Membre depuis le 18/06/2001, -26075 message
./45 -> Vu la procédure qu'il suit, c'est un paquet sur un repo pour sa distro, et c'est pour ça que je dis que c'est mal packagé. Le problème est là, et les paquets sources sont là, à 99.99% du temps, uniquement pour une question de license.


Bon d'un autre côté, les libs qu'il doit installer sont les libs de dev minimales dès qu'on veut faire un petit peu plus qu'un hello world. Typiquement c'est ce que j'installe sur n'importe quelle distro sans même attendre qu'on me le demande, je sais que j'en aurai besoin.

Golden -> Ah bon gcc est fourni en standard avec les distro ? J'ignorais. smile
Et encore une fois on est ici sur le paquet typiquement mal foutu par son mainteneur, ça remet pas en cause tout le système (encore une fois, des softs mal branlés sous Win, il y en a, ça remet pas tout en cause à ce que je sache).

(tripeulcross)
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 12/07/2010 à 14:05 Membre depuis le 16/06/2001, 69803 messages
ah bah tiens par zazard!
dedisol:~# apt-get install vim-full
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  aspell aspell-en console-common console-data dbus dbus-x11 defoma eject esound-clients esound-common fam fontconfig fontconfig-config gconf2
  gconf2-common gnome-keyring gnome-mime-data gnome-mount hal hal-info hicolor-icon-theme kbd libart-2.0-2 libaspell15 libatk1.0-0 libatk1.0-data
  libaudiofile0 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libcairo2 libcups2 libdatrie0 libdbus-1-3 libdbus-glib-1-2 libdirectfb-1.0-0 libdirectfb-extra libeel2-2.20 libeel2-data
  libenchant1c2a libesd0 libexpat1 libfam0 libfontconfig1 libfontenc1 libfreetype6 libgail-common libgail18 libgconf2-4 libglade2-0 libglib2.0-0
  libglib2.0-data libgnome-keyring0 libgnome-menu2 libgnome2-0 libgnome2-common libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0
  libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libhal-storage1 libhal1
  libhunspell-1.2-0 libice6 libidl0 libjpeg62 liblzo2-2 libmalaga7 libnautilus-extension1 libnotify1 liborbit2 libpam-gnome-keyring libpango1.0-0
  libpango1.0-common libperl5.10 libpixman-1-0 libpng12-0 libruby1.8 libsexy2 libsm6 libsmbclient libsmbios-bin libsmbios2 libsplashy1
  libstartup-notification0 libsysfs2 libtalloc1 libthai-data libthai0 libtiff4 libts-0.0-0 libvoikko1 libwbclient0 libwnck-common libwnck22
  libx86-1 libxcb-render-util0 libxcb-render0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxrandr2
  libxrender1 libxres1 libxt6 myspell-en-us notification-daemon pm-utils powermgmt-base radeontool shared-mime-info ttf-dejavu ttf-dejavu-core
  ttf-dejavu-extra usbutils uswsusp vbetool vim-gnome vim-gui-common vim-runtime x-ttcidfont-conf xfonts-encodings xfonts-utils
Paquets suggérés :
  aspell-doc spellutils unicode-data defoma-doc dfontmgr psfontmgr cdtool setcd cryptsetup gnome-device-manager libbonobo2-bin cups-common
  synaptic app-install-data esound libfreetype6-dev desktop-base gnome-icon-theme libgnomevfs2-bin librsvg2-common ttf-kochi-gothic
  ttf-kochi-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp libsmbios-doc
  voikko-fi cpufrequtils splashy cscope vim-doc
Paquets recommandés :
  libft-perl
Les NOUVEAUX paquets suivants seront installés :
  aspell aspell-en console-common console-data dbus dbus-x11 defoma eject esound-clients esound-common fam fontconfig fontconfig-config gconf2
  gconf2-common gnome-keyring gnome-mime-data gnome-mount hal hal-info hicolor-icon-theme kbd libart-2.0-2 libaspell15 libatk1.0-0 libatk1.0-data
  libaudiofile0 libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1 libbonobo2-0 libbonobo2-common libbonoboui2-0
  libbonoboui2-common libcairo2 libcups2 libdatrie0 libdbus-1-3 libdbus-glib-1-2 libdirectfb-1.0-0 libdirectfb-extra libeel2-2.20 libeel2-data
  libenchant1c2a libesd0 libexpat1 libfam0 libfontconfig1 libfontenc1 libfreetype6 libgail-common libgail18 libgconf2-4 libglade2-0 libglib2.0-0
  libglib2.0-data libgnome-keyring0 libgnome-menu2 libgnome2-0 libgnome2-common libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0
  libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libhal-storage1 libhal1
  libhunspell-1.2-0 libice6 libidl0 libjpeg62 liblzo2-2 libmalaga7 libnautilus-extension1 libnotify1 liborbit2 libpam-gnome-keyring libpango1.0-0
  libpango1.0-common libperl5.10 libpixman-1-0 libpng12-0 libruby1.8 libsexy2 libsm6 libsmbclient libsmbios-bin libsmbios2 libsplashy1
  libstartup-notification0 libsysfs2 libtalloc1 libthai-data libthai0 libtiff4 libts-0.0-0 libvoikko1 libwbclient0 libwnck-common libwnck22
  libx86-1 libxcb-render-util0 libxcb-render0 libxcomposite1 libxcursor1 libxdamage1 libxfixes3 libxfont1 libxft2 libxi6 libxinerama1 libxrandr2
  libxrender1 libxres1 libxt6 myspell-en-us notification-daemon pm-utils powermgmt-base radeontool shared-mime-info ttf-dejavu ttf-dejavu-core
  ttf-dejavu-extra usbutils uswsusp vbetool vim-full vim-gnome vim-gui-common vim-runtime x-ttcidfont-conf xfonts-encodings xfonts-utils
0 mis à jour, 140 nouvellement installés, 0 à enlever et 4 non mis à jour.
Il est nécessaire de prendre 48,7Mo dans les archives.
Après cette opération, 156Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? n
Annulation.
dedisol:~#
copaingtrilove
Posté le 12/07/2010 à 14:09 Membre depuis le 18/06/2001, -26075 message
Et il est où le souci ? Le rapport ? Vu les dépendances t'as un système over-spartiate (hal, dbus, eject, polices de bases sous X etc...), et tu demandes vim-full, il est où le problème ? confus
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 12/07/2010 à 14:12 Membre depuis le 29/10/2003, 25435 messages
Folco (./44) :
YN -> Si tu fais une croix sur ce nav et veut récupérer ton espace, vire juste le nav, tout le reste devrait dégager avec (en tout cas c'est le cas sous Debian, donc j'imagine aussi sur Ubuntu). :: Editer posticon.gif :: Citer


Je suppose qu'un apt-get remove <libs> devrait fonctionner, mais bon 200 Mo à gérer quoi moquette.gif
Posté le 12/07/2010 à 14:18 Membre depuis le 15/06/2003, 8330 messages
./50 > Bienvenue à bloatland warp
Folco (./49) :
./45 -> Vu la procédure qu'il suit, c'est un paquet sur un repo pour sa distro, et c'est pour ça que je dis que c'est mal packagé. Le problème est là, et les paquets sources sont là, à 99.99% du temps, uniquement pour une question de license.
Un autre grand problème. Que ce soit pour des problèmes de brevets ou autres (c'est chiant mais on y peut rien), soit. Mais de license... Vive les Kevin \o/
Et encore une fois on est ici sur le paquet typiquement mal foutu par son mainteneur, ça remet pas en cause tout le système (encore une fois, des softs mal branlés sous Win, il y en a, ça remet pas tout en cause à ce que je sache).
Soit, mais tu télécharge le binaire, tu testes, ça marche ou ça marche pas, ça te prend pas 3h. Après (si ça t'amuses ou que c'est vital) tu peux télécharger les dll manquantes si c'est ce qui foire et qu'il en manque pas 50, mais en général ça te prend également pas une éternité.
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 12/07/2010 à 14:50 Membre depuis le 18/06/2001, -26075 message
Yoshi Noir (./52) :
Je suppose qu'un apt-get remove devrait fonctionner, mais bon 200 Mo à gérer quoi

apt-get remove <le programme qui a nécessité toutes ces dépendances>
apt-get autoremove (et là, ce sont toutes les dépendances qui volent)

C'est ce que je ferais sous Debian.
GoldenCrystal (./53) :
Soit, mais tu télécharge le binaire, tu testes, ça marche ou ça marche pas, ça te prend pas 3h

Ah mais bien sûr triso Oh que si ça m'est arrivé, et le pépin, c'est que contrairement à Linux, j'ai pas toujours trouvé de solutions...
avatar<<< Kernel Extremist©®™ >>>
Feel the power of (int16) !
Posté le 12/07/2010 à 14:54 Membre depuis le 15/06/2003, 8330 messages
Le problème de apt-get autoremove (et équivalent sur tous les gestionnaires de paquets), c'est que si tu as eu le malheur de demander explicitement un des paquets dont tu n'as plus besoin, tout le système est niqué.
Il doit bien exister une commande permettant de trouver les paquets orphelins, mais c'est toujours le bordel à gérer.
(Forcément vu que tu as les paquets de dev et les paquets binaires à gérer séparément)
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 12/07/2010 à 14:56 Membre depuis le 16/06/2001, 69803 messages
C'est la fête aujourd'hui :
squalyl@dedisol:~/boinc_trunk$ sudo apt-get install libmysqlclient-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
  libmysqlclient-dev: Dépend: libmysqlclient16 (= 5.1.47-1~bpo50+1) mais ne sera pas installé
E: Paquets défectueux
squalyl@dedisol:~/boinc_trunk$
trilove et je fais comment moi?
Posté le 12/07/2010 à 14:58 Membre depuis le 15/06/2003, 8330 messages
Tu fais pas, vu que tu as demandé l'impossible. trioui
(C'est du testing / unstable ?)
avatarLe scénario de notre univers a été rédigée par un bataillon de singes savants. Tout s'explique enfin.
T'as un problème ? Tu veux un bonbon ?
[CrystalMPQ] C# MPQ Library/Tools - [CrystalBoy] C# GB Emulator - [Monoxide] C# OSX library - M68k Opcodes
Posté le 12/07/2010 à 15:02 Membre depuis le 16/06/2001, 69803 messages
c'est du debian 5 et c'est la premiere fois qu'il me prend le chou. Ca marchait, avant.

sinon: http://bugs.debian.org/cgi-bin/pkgreport.cgi?package=libmysqlclient . ouais, d'accord.
Posté le 12/07/2010 à 15:15 Membre depuis le 16/06/2001, 69803 messages
linux, c'est vraiment de la merde. Je passe 10 minutes à utiliser le programme debian "reportbug", tout ça pour me choper:

2010-07-12 15:11:46 1OYInS-0006if-Sl <= squalyl@gmail.com U=squalyl P=local S=2353 id=20100712131146.25782.20898.reportbug@host
2010-07-12 15:11:46 1OYInS-0006if-Sl ** squalyl@gmail.com R=nonlocal: Mailing to remote domains not supported
2010-07-12 15:11:46 1OYInS-0006if-Sl ** submit@bugs.debian.org R=nonlocal: Mailing to remote domains not supported
2010-07-12 15:11:46 1OYInS-0006ih-Vr <= <> R=1OYInS-0006if-Sl U=Debian-exim P=local S=3269
2010-07-12 15:11:47 1OYInS-0006if-Sl Completed
2010-07-12 15:11:47 1OYInS-0006ih-Vr ** squalyl@gmail.com R=nonlocal: Mailing to remote domains not supported
2010-07-12 15:11:47 1OYInS-0006ih-Vr Frozen (delivery error message)


ALLEZ VOUS FAIRE TATAOUINER!
Posté le 12/07/2010 à 15:17 Membre depuis le 28/10/2001, 7625 messages
squalyl: interaction entre le repository de base Lenny et le repository backports, voir http://packages.debian.org/search?keywords=libmysqlclient-dev .
Manifestement, ce que tu veux, ici, c'est `apt-get install libmysqlclient15-dev` wink
avatarMembre de la TI-Chess Team.
Co-mainteneur de GCC4TI (documentation en ligne de GCC4TI), TIEmu et TILP.
Co-admin de TI-Planet.